5

Indesign seems to support the addition of custom keyboard shortcuts for paragraph styles.

In the current version of Indesign CC the text box is there, but no matter what I try to type I can not set any values or even manage to type anything in the box.

Some online sources suggest to hold down a command key and a number key and that I must have a keyboard with a numeric pad, but since I don't have such a keyboard on my macbook I'm still stuck and this seems silly that it can only be set with the right keyboard.

How do I set a shortcut to something like +3 or whatever the syntax is?

enter image description here

  • If you found one of the answers below useful please mark it as the accepted answer. – DᴀʀᴛʜVᴀᴅᴇʀ Nov 29 '17 at 18:50
8

I'm sorry to say, but it is not possible on a keyboard without a number pad.

You need to use the number pad numbers, for your shortcuts, not the regular ones.

You can still edit keyboard shortcuts through the Edit > Keyboard Shortcuts menu, but you can't assign Paragraph or Character Style shortcuts.

I've found that using the Paragraph/Character Style window(s) can be a fairly quick alternative. Open them under Window > Stlyes. This will allow you to easily pin them to your right-hand toolbar.

As you can see below, a window opens up with your styles listed. Move your cursor to the paragraph (or highlight the characters) that you want to change, then simply click the style you'd like to apply in the list.

enter image description here

I did also find a workaround (by installing a 3rd party app) here, but I never tried it

Sources:
- https://forums.adobe.com/thread/324960
- http://www.mac-forums.com/images-graphic-design-and-digital-photography/189844-indesign-and-styles-keyboard-shortcuts-macbook-pro.html

  • Thanks John so much for your links and confirming my suspicions. How you suggest is what Im doing currently but it's not keyboard driven so it doesn't answer my question. I've summaries the other tips I found via the links you provided to provide a trail for future visitors and plan to just accept my answer (but I've given you an upvote). If you want me to accept your answer instead I think if you highlighted the keynoard alternatives mentioned over the mouse driven option Im happy to accept yours instead as credit goes to you. Thanks so much for your help. :) – Evolve Jul 24 '16 at 8:31
3

Unfortunatley it is not possible on a keyboard without a number pad.

Alternative 1: Use Quick Apply

I find it easier to use Quick Apply (Cmd/Ctrl + Return/Enter) and type a few letters of the style name or other command. There are a couple of ID commands that are not on menus or accessible through keyboard shortcuts, that aren't accessible via Quick Apply.

Source: https://forums.adobe.com/thread/324960

Alternative 2: Add support by installing a keyboard customiser

Otherwise explore installing a tool like this:

Use the app Karabiner (https://pqrs.org/osx/karabiner/). It can remap fn + number to fn + numpad number. With Shift+fn+1 you have Shift+Num 1. It works.

Source: https://apple.stackexchange.com/questions/107599/creating-indesign-paragraph-character-style-shortcuts-on-a-mac-wireless-keyb

  • A third way is more convulated: write a script that does nothing but applying the style, then apply a shortcut key to that script. (It's "more convulated" because every style needs a script of its own, and keyboard shortcuts are system-wide, so you may end up with hotkeys for styles that are not in your current document.) – usr2564301 Jul 24 '16 at 14:21
  • "Use Quick Apply" is great on notebook, almost same fast as shortcut. – Matěj Kříž Jan 23 at 9:27
0

You don't type anything in there; click on the input field on the right side of the "Shortcut:" and press the actual shortcut you want (for example, if you want +3 you actually press and 3, don't try to type it).

If it doesn't accept your shortcut, you need to try another key combination.

  • Thnx for your answer, how you suggest is how I imagined the feature should work (like the keyboard shorcuts feature in OSX keyboard settings). However my friends and I have tried many combinations on a number of computers and no input is working, hence my question. Yes this should work but isn't. If you wanna try inDesign and see if you can get any progress would love any further ideas you have. Thx :) – Evolve Jul 24 '16 at 8:13
-1

First of all you need to be sure the shortcut you want to assign is not used by InDesign or any program running in the background. Try some strange shortcut like CMD+ALT+J.

protected by Community Apr 13 at 20:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.