5

When I go to print a pdf file with "Adobe PDF printer", I get the following error:

cannot complete command because read or write access has been denied.

This very strange error only appears if I change the paper size in the PPD settings. If I leave the default A4 size the PDF is generated without any problem.

When the error comes to light I need to delete the fhprefs.txt file. I tried to put somenthing like "whatever" in the export preferences of freehand, but that did not solved the problem.

  • 3
    Adobe has wrapped Freehand in rolls of duct tape to keep it together and running. This isn't much help, but I wouldn't depend on FH too much longer. I've found that sometimes you can get OK results using FH's PDF export option and/or Print to PDF in OSX, but even then I sometimes have font embedding issues. – DA01 Feb 3 '11 at 15:10
  • I know what you mean...but I need to use my PPD printer files and It with the export PDF function of FH I can't use them... – cubob Feb 4 '11 at 7:50
  • Are you able to print to a regular PostScript file? You could let Distiller handle the PDF compression after. It might simplify the process – GoofyMonkey Jun 16 '14 at 19:42
2

You don't mention the OS, but this may be a permissions issue. Perhaps if you ran freehand as administrator.

| improve this answer | |
  • Sorry...my OS is Windows 7 ultimate 64bit. Anyway I yet tried to launch it as administrator but nothing... – cubob Feb 4 '11 at 7:47
0

I am using Freehand MX on Windows 10 Professional and I have found the solution for PDF export here is, to first save your Freehand document as an older version of Freehand. You can EXPORT your Freehand MX files as Freehand 8, 9 or 10, then close your MX document. Then open the Freehand 8,9 or 10 document and export as PDF. Perfect results every time without any error messages, don't ask me why. I have used Freehand MX on Windows XP, Vista, 7 and 10, and mac OS 10.6 and this seems to work in the year 2020.

| improve this answer | |
New contributor
Nick John Child is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.