1

I have been trying to save an .ai vector as an .eps, but no matter what settings I try, the result is a heavily pixelated raster image. How can I get a clean vector EPS instead? What causes Illustrator to act up like this?

The original vector quality and the resulting EPS

I save as Illustrator 10 version, 8-bit transparent, "Include CMYK postscript" checked, tried both checked/unchecked "Compatible Gradient". If this matters, the vector image contains transparency, gradients, pattern fills, a clipping mask. Reading up on the issue told me that EPS may have troubles with transparencies and gradients, but saving as Illustrator 10 is said to take care of this. Never had this happen to other vectors with the same settings and elements.

4
  • 1
    How are you checking the result? EPS may include a low resolution bitmap preview. Is it possible you are seeing that instead?
    – Jongware
    Commented Aug 12, 2016 at 23:35
  • I close the file and reopen it in Illustrator, and that's how it comes out. It is possible, but time after time this EPS gets rejected from Shutterstock for bitmapping. There are no linked images or anything else that "Document Info" would reveal as a source of bitmapping.
    – aveleen
    Commented Aug 13, 2016 at 9:08
  • 1
    What are your Document Raster Effects Settings? (Effects Menu). Have you tried manually flattening the transparency first (Object > Flatten Transparency). Although AI10 EPS will be aware of transparency settings things still get flattened.
    – Scott
    Commented Nov 2, 2017 at 16:43
  • Thank you for this advice! This is the only thing that seems to have worked. Unfortunately, it made the whole EPS twice as large as could be accepted by Shutterstock, but hey, at least I can sell the high-quality JPG now. I've looked into ways of making it less heavy, but it appears that, short of removing all transparencies and gradients, there is nothing that can be salvaged.
    – aveleen
    Commented Oct 3, 2018 at 16:42

1 Answer 1

1

If you've definitely set the 'preview format' to none when saving, then all I can think is that you could be using blends (possibly radial) and/or transparencies in your illustration that can't be accounted for in the the version of the eps coding your selecting.

Maybe try a few differing (legacy format) versions of eps...see if it resolves it.

1
  • The thing is, I did nothing that I hadn't done in any of my other artworks, but this is the only time I've encountered this bug. Blends and transparencies have always been saved without problems, I use the same settings all the time. I'll keep looking for a solution... Thanks!
    – aveleen
    Commented Oct 3, 2018 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.