2

So this is driving me absolutely crazy. I have created this svg of a gear that features a shadow only on the inside. Also it's important to note that this "inner-shadow" is it's own object, and consists of a fill and a stroke that are basically both the outline of the gear shape in black and grey, but somehow when I blur or unblur it t0 0.8% the effect only happens on the inside. I am trying to reproduce the same design, but I cannot remember exactly how I did it and now when I attempt to blur it, it doesn't look the same at all. Using the Filter "Cutout-Glow", I get nearly the same results, but it only works when there is a fill present. As mentioned before on the other examples the fill color is an entirely different object beneath the outline. This imgage shows exactly what I'm trying to recreate: enter image description here

Any help or insight is greatly appreciated!

  • What is your question? Which of the five gears above are you trying to reproduce? Please clarify... – KlaasNotFound Aug 25 '16 at 10:37
  • They are all the same gear actually. I simply tried to show that the "stroke/shadow" are separate from the fill color. Also the very bottom right-most one has no blur added. – DroWnThePoor Aug 26 '16 at 14:37
4

I am assuming that your question is:

How do I reproduce the same gear design that is visible in the image?

You can reproduce the effect by applying the "Drop Shadow" effect twice.

You might have done it differently and surely there are several ways to achieve the effect. Here's how I did it, based on what could be observed in the image:

  1. Create the base shape (the gear with a gradient) without any stroke.

  1. Duplicate the shape. Select the first copy and apply "Filter" > "Shadows and Glows" > "Drop Shadow" with the following settings:

    Use a black shadow with high alpha (RGBA 000000c8) in the "Blur color" panel.

We're basically already there (the southeast shadow looks good), but notice how the original also has a slight shadow facing west. Let's create that.

  1. Select the second copy and apply "Filter" > "Shadows and Glows" > "Drop Shadow" with the following settings:

    Don't forget to choose "Inner cutout" for the shadow type. Again use a black shadow with high alpha (RGBA 000000c8) in the "Blur color" panel.

  2. Center the second copy on top of the first. You may use "Align and Distribute" (Shift+Ctrl+A) for this. This should give you the final result:

That's it.


A remark regarding the "blur problem" that you experienced: After you apply an effect that uses blur (e.g. "Cutout Glow" or "Drop Shadow") to an object, the "Fill and Stroke" panel will show some percentage value for the blur property. I believe this is some sort of average of the different blurs applied to the object as part of the effect (an effect could have a heterogenous mixture of different blurs, that's why it's an effect and not a simple slider).

If you then alter the blur value via the slider, the object's blur will be completely messed up (like you experienced). In other words: Don't touch the blur value after you have applied an effect. If you must control the blur of a stroke outline, duplicate the outline before applying the effect and work with the duplicate. But as you saw, the overall effect can be achieved without using a stroke outline at all.

  • Thank you sir, I appreciate you going through all of this. It's a great answer and I greatly appreciate it. It's about as close as I've gotten. I'm going to mark as solved. – DroWnThePoor Sep 3 '16 at 4:54
  • I know this is a bit after the fact, and I'm not even sure if this is the best way to ask for further explanation. But in your answer you mention selecting the other copy and applying he inner-cutout, in your illustration the cutout copy has no fill, how do I accomplish this? When I empty it of a fill, there seems to be no effect to applying the Filter. Regards, J.H. – DroWnThePoor Sep 10 '16 at 14:15
  • @DroWnThePoor The "Inner cutout" shadow removes the fill (as opposed to the "Inner" shadow), so you simply apply the effect to the filled shape (the exact duplicate of the first object). You can try it out by checking "Live preview" and choosing the different shadow types in the effect dialog. – KlaasNotFound Sep 10 '16 at 16:38
  • Hmm, this is strange, either I'm not doing this correctly or there's something different about my Inkscape. I am running .91 but I wouldn't think that should matter. I select the gear shape, with it's gradient, apply inner just the way you have posted and it adds the shadow effect but the fill coolor remains. – DroWnThePoor Sep 12 '16 at 13:36
  • @DroWnThePoor I'm using v0.91on a Mac so nothing suspicious there... Here's what switching the effects should look like: i.stack.imgur.com/W8QOq.gif – KlaasNotFound Sep 12 '16 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.