I am running into an odd problem. I have Adobe After Effects installed and I am not able to import PNGs with transparency. Each time I import a PNG with built-in transparency, the PNG gets a black background.

I have tried importing the same PNGs into Photoshop and it imports them correctly.

Any ideas as to why this is happening?

  • Is there actually anything behind your PNG in AE? The default background is black, so your transparency will look black unless there is anything behind it or you change the background.
    – Cai
    Commented Sep 7, 2016 at 8:14
  • The PNG is absolutely transparent. There were PNGs that i had imported before without any problem. I used to get the transparency. But i guess since 2 months or so i am getting this weird black background even on PNGs i used before. Commented Sep 7, 2016 at 13:07
  • Ok, but you didn't answer my question... Is there anything behind the PNG or have you changed the background color? The default background is black.
    – Cai
    Commented Sep 7, 2016 at 13:10
  • There is nothing behind the PNG. Concerning the default background color if i put a red background behind the transparent PNG even then parts of the PNG that are supposed to be transparent are not transparent but instead they get a black background Commented Sep 7, 2016 at 13:13
  • Does the PNG have alpha transparency or is it indexed? I assume its still black if you toggle the transparency grid on?
    – Cai
    Commented Sep 7, 2016 at 14:17

9 Answers 9


Change your Composition Background Color in After Effects, which is black by default :)


Are you importing it instead of just dragging and dropping it?

If it's importing correctly in photoshop, you could try re exporting through it. File>Export>Save for web. Select PNG format. (PNG 24) Make sure transparency is checked. Uncheck convert to sRGB


Make sure to save your .png file as 16 bit depth or higher. 8 bit will not retain an alpha channel when imported into After Effects.


If you have an image without a background, you can just save it in png format.

  1. Click File → Save As
  2. Choose a name of your choice and select png format by clicking the drop down menu.

This will save in real png format, with proper transparency.

  • Hi Jackie. Welcome to GDSE. Unfortunately, I don't think your answer actually answers the question, which is not how to save a PNG, but how to import a PNG with a transparent background into Adobe AfterEffects. The OP already has a PNG file.
    – Billy Kerr
    Commented Sep 15, 2018 at 12:12

I found 2 issues that are affecting me. For me, it is down to Google Chrome blocking the JavaScript, so the image is seen as a document. Even if I save the file, I can an error "Not a PNG file", but it is.

None of the above and on 50 different website answers work for me. I clear the cache and reset Photoshop and the Browser. The same error. I come across the article where somebody mention Chrome blocking the JavaScript. That only happens on certain websites. I was able to save the other PNG and open it, just fine. Save it. Not copy. I checked my browser and I had a similar error in Developer Tab:

  • image/x-png MIME type

Chrome apparently does not support the x-png. This is the way that the server sends a picture. That was the Autodesk website.

The files are also saved as WebP format. Chrome is not doing very well when picking up that file. I can save some PNG's, but not the banner with the logo from the Autodesk page. I tried everything, using just Chrome and Photoshop. Nothing. The advice below also doesn't work, or I come out with a similar one.


To save that file I have 2 choices: 1. Use Chrome and save the file that is 7kb large and throws an error that this is not a PNG. When I checked with file reader for images data, there is no metadata. I can open it in Paint 3D and it will open with transparency. Save us PNG and it will be PNG. You can now open it in Photoshop.

  1. I open Microsoft Edge and try to save it from there. It is a 25kb file (same size as in re-saving it in Paint3D). That opens straight on with transparency.

So. It is a file format WebP and the x-png process that knocks them down.

Why I suddenly lost the capability of copy and save with transparency, I have no idea. I get a few large updates from Microsoft, as I sign up to Insider program. Funny. At the end of the day, I would like to work out, how the file with 2/3 of the missing data, can still open in Paint3D with transparency. Copy/paste just stopped working for me. WebP plugin for Photoshop doesn't work for me too.


File/Place embed

That should do the trick.

Even if chrome show it as black background, save it to hard drive. It will change to transparent. open your destination file. Press File/Place Embeded.

  • Welcome! What has chrome to do with the question? I can not see it mentioned in the question ...
    – Mensch
    Commented Jun 5, 2019 at 19:08

I had this problem but I wasn't saving my PNGs as interlaced. Just changed now and transparency works Maybe this helps


If you are exporting the .png from Photoshop or Illustrator, try not to use "Save for Web" the CRNT/CM+ALT+SHIFT+S.

Instead use the "normal" save / export settings, set at 150ppp or above and mark transparent background.


Make sure that the Image Mod is set at "RGB" in Photoshop while saving your "Png" File.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.