3

enter image description here

I am trying to export print files from a large template file. Why are my layers showing up in the PNG and how can I get it to stop? Exporting to screens does not help.

  • I just noticed this issue too. So dumb :( – Nick Bedford Sep 15 '16 at 4:40
1

In my case, it was an issue with nested layers. Even though a parent layer was set to hidden, the layers within were set to visible and would show when exporting.

I was able to fix it by hiding the inner layers instead of the outer layer.

  • 1
    Hi spencer.sm, welcome to GDSE and thank you for your contibution. Your answer seems about right to me, but maybe you can expand it a bit by adding some info or a screenshot as where to find the nested layers. Thanks for your time and effort and keep contributing! – PieBie Oct 25 '16 at 6:51
0

The workaround works, but is not feasible when you can have dozens, if not hundreds of sub layers. The only solution I've found then is to open the vector file in Photoshop and save it as PNG from there. Very annoying.

0

Possible...

Make certain Overprint Preview is not active -- View > Overprint Preview - Or the checkbox on the Separations Preview Panel.

Overprint preview tends to do really odd things if it's on and you try to "Save for Web" such as ignoring the visibility state layers, ignoring blending modes, etc..

0

Export selection! Try Export Selection on the actually assets you want to Export. This worked for us.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.