0

I'm putting together an InDesign document (CC 2015.4, Mac) and am using RTF files to manage and maintain the textual content. However, when I place text from an RTF file created using TextEdit, my italics and bolds appear to be lost. When placing the cursor in the placed text where there should be a style, I don't see a plus next to [none] in the Character Style palette or next to my chosen Paragraph Style.

Even when I paste the text and set my preferences for 'Clipboard handling' to include 'All information (Index markers, Swatches, Styles, etc.)', even though the pasted text is set to the 12pt Helvetica in the original TextEdit document, with auto-leading, etc. With the addition of a blue background which I cannot account for, the italicised portion of the text shows no indication that it ever was italicised, be it in the character style palette (which seems where it should be intuitively) or the paragraph styles.

Does anyone know how to place RTF text using the basic styles in a way that preserves, or enables mapping of those styles?

1

When you place (CTRL+D on Windows) an RTF or DOC/DOCX, make sure you check the "Show import options" box in the "Place" dialog. Then you should get this window with import options, some of which will address your issue. This is the usual Word importing routine if one needs to use styles from Word/RTF. This is known to be faulty sometimes, but should generally work depending on your RTF consistency.

enter image description here

If for some reason you dont get this window, there must be something wrong with your RTF file, mainly in the way it defines styles. Since i'm not using TextEdit i can't really test to see how it saves to RTF, but its best to save your RTF using Word if thats available, or just try to format source file via Google Docs and import from there.

I would assume TextEdit is making your styles somehow inaccesible to Indesign.

  • You're correct -- it appears that this is a TextEdit issue. Copying and pasting the text into an MS Word doc and saving as an RTF seems behave as expected. – Tricky Sep 16 '16 at 16:06
  • Glad this helped ! – Lucian Sep 16 '16 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.