I keep coming across this problem randomly in my documents.

I’d like to Free Transform → Perspective Transform, but the option is grayed out.

If I hit Ctrl/Command+T and then drag one of the handles while holding Alt/Option, I’m not able to move each handle independently (Perspective Transform). It reverts to the Skew transform which is not what I want (see image).

I can do this in certain documents but not others. I should mention that I’m trying to transform a linked AI file in PS. However, I’ve done the same thing with a linked PSD.

2 Answers 2


I just tested this out by copy/pasting an AI object into a PSD. I can confirm that many of the Transform operations are disabled as you said.

To remedy this, I right clicked on the Vector Smart Object layer and chose Convert to Smart Object. Now I have a Smart Object of a Smart Object and all of the Transform operations are enabled.

So if you want to edit the original vector in AI, then double-click the layer, and it'll open a .psb, then double click the layer there and it'll open an .ai

Would this work for you?


It's possible I just answered my own question, but can anyone confirm this? That only with a linked or embedded smart object PSD (not AI) can I Perspective Transform the document? It appears that I only see this with AI linked or embedded.

Figured if anyone else has this problem, that at least we'd have a question complete with an answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.