1

I have a problem. I'm working with an object at 50% opacity. When it's over the artboard itself the color looks great, but when I put a white object behind it I get this weird color that doesn't look accurate.

This happens with every object and only in CMYK. I'm pretty sure this never happened to me before so maybe I changed something in the settings or I don't know.

Does anyone have any idea?

screenshot

  • What version, what rasterizer are you using (software or hardware in CC). Blending may need to roundtrip in certain cases and that could caouse this to happen. – joojaa Oct 14 '16 at 6:23
2

I'm not 100% sure what's going on here but I can tell you that what you see blended with the white object is actually the correct color. If you do as you did in your example with a 100% K square, you will see that the part over the white object is 50% K while the part blended with the artboard is something else.

If you turn on overprint preview (View → Overprint Preview) you will see no discrepancy and artwork blended with the artboard will look as it does blended with white (i.e. what you though wasn't accurate). If you select your artwork and flatten transparency (Object → Flatten Transparency...) or rasterize (Object → Rasterize...) you will see that it corrects the color to what you see when blended with white.

Now, weirdly if you change your document to RGB you see the color as it was over the artboard—not over the white object. But, if you flatten transparency and switch back to CMYK (so your color looks how you initially wanted) you'll see the values are wrong. So it seems like Illustrator works out the preview for transparency over the artboard (i.e over nothing) in RGB—but as I said before, I'm not really sure.

Also (I just checked), if you go to document setup and turn on "Simulate Colored Paper" and set the color to white, you get the correct colors (the same as you normally get when blended with a white object).

Basically don't rely on transparency blended with your artboard.

(Also, I'm using CS6 so this isn't new in CC)

  • I think it needs to pump ther values trough the color engine and the background does not participate in the color mode and i set in RGB? Most likely not simulating paper. The ICM offcourse has to work out the color in some colorspace so it often is a roundabout just there. I hate color correct programming as its just so damn hard to get it ALL rtight, one slipup somewhere ane yoru back to square 1. – joojaa Oct 14 '16 at 8:58
  • Yeh makes sense, no idea why they wouldn't just simulate white paper by default though. Good ol' Adobe. – Cai Oct 14 '16 at 9:02
  • That makes sense! And yeah, I think that's nothing new and I just notice it. I tried to do the "Simulate Colored Paper" thing but it doesn't work, the issue is still there. So I think I will have to place a white square every time I start to work on a new file. – Azael Carrera Oct 14 '16 at 18:35
0

Never noticed this happening but I just opened my illustrator and replicated what you show on your image and mine does it too. The only logic explanation I can come up with is that the programme's way of "thinking". And this is just a guess but, if you have no objects behind it the colour does not change because the white of the artboard is considered as "nothing" - not an object and no colour.

As oposed to when you put a white square behind it, telling illustrator : this is an object with a white colour.

In CMYK mode it will take vibrance away from your blue because it replicates the behaviour of colours as pigments and not as light. If you change is to RGB you can notice that it also changes a bit but because RGB adds light to the colours the difference is not so evident.

Image of the colour difference when you change the document settings to RGB below.

RGB MODE

  • You're right!! The color also changes in RGB mode. It would be better if the artwork acts just like a white background. I have so many files with transparency and just the artwork as a background and now I realised the colors in all of them are maybe wrong. – Azael Carrera Oct 14 '16 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.