0

This question was asked here How do I paste into a layer's mask in Photoshop?

but none of the answers work for me! It seems to be a common question on the web, but something is going on with my situation, because absolutely zero of the suggested solutions work.

I'm trying to paste the contents of one layer A into the new layer mask of another layer B, using Photoshop CC on OS X.

I select all of A and press Cmd-C. Then I try any of the following:

  • Click the "add mask" icon of layer B while the copied image is in the clipboard. I am told this will put it in the mask, but the mask is blank.

  • Alternatively, add the mask to B first, then click on it, then Cmd-V. This pastes the clipboard into an entirely new layer.

  • Alternatively, add the mask to B, then click on it, then Shift-Opt-Cmd-V. This does the same thing as Cmd-V.

  • Alternatively trying any of the Paste Special commands from the Edit menu. These all do the same thing as Cmd-V

EDIT: It occurs to me that maybe the problem has something to do with the fact that layer A is RGB, while masks are grayscale.

EDIT 10/17/2016 This is solved. I am new to the Mac world, and when I read the instruction to Alt-Click, I was doing Cmd-Click, when what I actually needed to do was Opt-Click.

1

Two options.

  1. Manually select the mask channel from the Channels panel. Doing this will allow you to edit the mask with the rest of your artwork still visible.

  2. alt+click the layer mask thumbnail in the layers panel. This will automatically select the mask channel and hide all other channels.

Any artwork pasted to a mask channel will automatically be converted to grayscale, so you can copy RGB layers with no problem.

Take this image for example:

enter image description here

After copying the image, I add a new gradient layer, alt+click that layers mask thumbnail in the layers panel and paste the image:

enter image description here

Adjust the mask using a levels adjustment:

enter image description here

Invert the mask then deselect the layer mask in the layers panel:

enter image description here

  • Oh, I figured out what the problem is. I'm new to Mac, come from Windows. When you (and other people) write to "Alt-Click" the mask, I was doing a Cmd-Click. What is actually needed is Option-Click. It works now. Sorry for the confusion. – composerMike Oct 18 '16 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.