9

This is a problem I have been having recently. My screen size has a pretty high pixel density and, as a result, all of GIMP's icons are criminally small and very difficult to look at.

I've tried searching for ways to increase the screen size but all that shows up is how to scale images. Thing is I know how to change the image DPI but I want to know how to change the actual program's DPI, so that the icons are better suited to my computer screen.

  • 1
    This is more suitable for the superuser.com SE - unless you want to help us to design bigger icons, of course :) – Michael Schumacher Oct 22 '16 at 18:10
  • I'm sorry, I assumed this would be appropriate for this Stack Exchange. what is superuser.com SE all about? – Emerald Eel Entertainment Oct 22 '16 at 19:31
  • About the usage of software - which is what this question is about. – Michael Schumacher Oct 23 '16 at 9:31
6

A simple solution for GIMP 2.10 (both under Linux and Windows):

  1. Go to "Edit → Preferences".

  2. In the Preferences dialog, go to "Interface → Icon Theme".

  3. From the dropdown at the bottom, choose "Use icon size from the theme" or "Custom icon size" (and in the latter case, choose your icon size with the slider below that).

The problem you describe happens because by default it's "Guess icon size from resolution", which considers only the resolution and not the physical size / DPI settings of the monitor. Worse, in a dual-screen setup it considers the combined resolution.

  • 1
    This also works for Windows using Edit > Preferences, not under "Tools". – Billy Kerr Jan 13 at 14:38
  • 1
    @BillyKerr Thanks! Edited my answer accordingly. – tanius Jan 13 at 16:40
5

I have gimp 2.8 on Windows 10 and this is what solved the small tool icons problem for me: open This PC > Local Disc (C:) > Program Files > GIMP 2 > bin, right click on gimp-2.8, open Properties, click on Compatibility. On the settings options select: Override high DPI scaling behaviour. Scaling performed by, scroll and select System, Apply, OK

  • 1
    Yes, but that means that everything is bigger, including selection lines and such? – xenoid Feb 15 '18 at 9:06
  • This kind defeats the whope point of having a High-DPI monitor for image manipulation though. – FrankyBoy May 19 '18 at 12:35
2

The size of the tool icons (brush, move, selection etc) of GIMP's UI can be configured in the gtkrc file.
Try find this line in gtkrc file:

GimpToolPalette::tool-icon-size   = <size>

Where <size> is an written identifier (instead of a number like you might expect), with names like

  • menu
  • button
  • large-toolbar

I personally set my icon sizes to button which is bigger than the default (which I think is menu).
I think large-toolbar is the biggest.

So maybe try something like changing the line to:

GimpToolPalette::tool-icon-size = large-toolbar
  • I tried to find the GimpToolPalette section in this custom theme I downloaded but it doesn't seem to be there. :o – Emerald Eel Entertainment Oct 23 '16 at 9:25
  • @EmeraldEelEntertainment GIMP uses cascading config files where entries in your user gtkrc will override those in the system GIMP gtkrc so just try pasting the line into your gtkrc and see if that increases the icon size – the_velour_fog Oct 23 '16 at 9:32
  • I copied and pasted the line into the gtkrc file of the theme I downloaded, and change it to button. I reloaded Gimp but nothing has changed. :( – Emerald Eel Entertainment Oct 23 '16 at 10:56
  • @EmeraldEelEntertainment what about using large-toolbar? – the_velour_fog Oct 23 '16 at 10:58
  • I will give that shot and see what happens. – Emerald Eel Entertainment Oct 23 '16 at 13:05
1

You can use Kevin Payne's themes with big icons: these are available and discussed here.

  • I'll give it a shot! I was curious to ask because I used a custom flat icon theme. – Emerald Eel Entertainment Oct 23 '16 at 9:21
  • Okay, I downloaded and applied the theme; the text us much clearer but the icons haven't changed in size too much. – Emerald Eel Entertainment Oct 23 '16 at 9:39

protected by Community Oct 21 at 11:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.