I'm making a texture for a game and it needs to have Metall in the RED channel, Glossiness in the GREEN channel and Ambient occlusion in the BLUE channel.

I have all these as separate grayscale (RGB) layers in Photoshop CS6 and need to transfer each layer into the corresponding RGB channel.

I have tried to filter out each color in the layer, but they don't mix if they overlap.

  • I use the Channels panel, and turn off all but one component (R,G, or B). Then copy the image in/out of the document.
    – Aaron
    Commented Oct 26, 2016 at 21:21

5 Answers 5


Your own answer is really close, but there is a better way...

You can use ADJUSTMENT LAYERS to strip the unwanted channels out of each layer rather than deleting them by hand. This is non destructive so your file can stay layered and 'live' and it will be easy and quick to implement additions and changes. There are a couple of different adjustment layers that can be used for this; I've gone with CHANNEL MIXER, but CURVES would work just as well, for example. Whichever you use, you just need to remove (make black) the two channels that you don't want in each case. As you found, the layers need to be set to sccreen.The key is to make sure that the adjustment layer is only acting on the layer directly below it by selecting the 'clip to layer' option.

Below is a screenshot showing the set up in layers and the resulting channels. I'm using CC so the appearance of the palettes and the wording of the options might be slightly different to those that you see, but hopefully this will be enough to guide you to the solution.

enter image description here

If you create a template PSD file with the appropriate adjustment layers then you can just drop your components in to the appropriate locations in the layer stack each time for a quick and easy workflow.

  • Also a fill layer with monochromatic color set to multiply would work.
    – joojaa
    Commented Oct 27, 2016 at 10:43
  • "Final step: flatten before or during export"
    – Yorik
    Commented Oct 27, 2016 at 14:31
  • Thank's chris. Yes, I tried the Channel Mixer, but that was before I figured out the "screen" mode :D Yes this is the simplest way to do it that still offer maximum control. Commented Oct 27, 2016 at 23:11

Try this:

Make a new RGB file of the same size as your original grayscale source images.

Open your channels panel, turn on only the desired channel and paste the corresponding grayscale image on it.

enter image description here

Old version:

enter image description here enter image description here enter image description here enter image description here

  • I tried that, but since the RGB channels are somewhat "Live" they change depending on what Layer I'm turning on/off. Commented Oct 26, 2016 at 21:45
  • It works perfectly fine. Be sure you are selecting only one channel when you paste it, and the images are grayscale mode.
    – Rafael
    Commented Oct 26, 2016 at 22:21
  • I'm not sure if you use the same version of CS as me, but that doesn't work for me. The layer have gray levels in RGB, so it is already present in all layers. I also tried to copy the layer, create a new layer and made it the only visible and active layer, went to channels (empty), selecting red channel and paste. But all I got was a selection of my copied layer, no gray scale was painted. Commented Oct 26, 2016 at 22:39
  • "The layer have gray levels in RGB" No, that is NOT a grayscale image, that is simply an unsaturated RGB file. The Photoshop version is Irrelevant. The version on my example is quite old. I am not using my main computer.
    – Rafael
    Commented Oct 27, 2016 at 0:04
  • 1
    Copy a grayscale image into one channel. It is a simple operation. Newer versions work exactly the same. You do not copy a layer, you copy a grayscale image.
    – Rafael
    Commented Jul 24, 2018 at 0:42

Photoshop-File-Scripts-Load Files into Stack

Add open files

Layer Blending options - Choose correct channel

Kindly see attached screenshots of Photoshop. I already opened the individual files before making a stack. Since all input files were only grey, I converted the stacked image to RGB before applying layer blending options.


I think I figure it out.

  1. Show only "red" layer
  2. Go to channels and select Green and paint it black
  3. Go to channels and select Blue and paint it black

  4. Show only "green" layer

  5. Go to channels and select Red and paint it black
  6. Go to channels and select Blue and paint it black

  7. Show only "Blue" layer

  8. Go to channels and select Red and paint it black
  9. Go to channels and select Green and paint it black

Maybe there is an easier way, but this did the trick.

EDIT: No this didn't work either. Overlapping areas doesn't mix. So after editing the channels as described above I went back and changed all layer modes to "Screen", now the colors mix correctly.


A greyscale image is not RGB, so if the grey image is truly RGB, convert the mode to greyscale.

Copy the greyscale image, start a new RGB document (this will auto-set the size in the dialog to match to the size of the clipboard) go to a the channels palette, select the correct color channel, and then paste.

Copy and paste from the other two greyscale documents into the correct channel on the new rgb document.

  • I mean that the image mode is RGB, but each layer is in gray (R=G=B) Commented Oct 26, 2016 at 21:45
  • "color channels in a new document". Provided there is not some software specification you need to follow, from a storage and memory standpoint, there is no reason to use R=G=B documents. They are three times as large, and on a decent project you may be making thousands (or 10s of thousands)
    – Yorik
    Commented Oct 27, 2016 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.