4

I have pixel grid turned off. I have all snapping turned off. But yet, when I try to combine two objects with an even size using pathfinder it adds .083mm to it. Any idea how to stop this? See images before and after: enter image description here

enter image description here

  • I could not replicate your problem here - could you try create the circle with whole figures then ADD (with Pathfinder) a single long shape rather than 2. Just to see if there could be a strange anomaly. – Mark Read Nov 14 '16 at 21:57
  • 11
    You have align new objects to pixel grid on. This causes the merge to snap the points to the pixel grid. You can see this in the second image. – joojaa Nov 15 '16 at 4:36
4

Illustrator's Pathfinder is only so good, meaning, it isn't 100% precise. In your case I believe you may have hit one of those very easily noticeable cases. It may also be due to the "Align to Pixel Grid" being on.

As @joojaa mentioned:

You have align new objects to pixel grid on. This causes the merge to snap the points to the pixel grid. You can see this in the second image


You can go to WindowPathfinderdrop-down menuPathfinder options

Now change the precision. The lowest (and default) you are able to set the precision to, is 0.028*. (That's in CS6, which I use, I'm not sure about CC).

*If you write 0.000000001 it automatically changes to 0.028


enter image description here


Some people talk about it on Adobe Forums here: https://forums.adobe.com/thread/2246376

I'm not sure if this is the reason that you're having issues since nobody was able to replicate it, however, it does seem so, based on the Adobe Forum discussion.

| improve this answer | |
  • 1
    +1 THe lowest you can set the value is "0,001" pt... or atleast thet is the smallest number the GUI allows you to put. Intersections of beziers is not actually possible to do efficeiently with analytical pecision. In either case 0.028 pt precision would only cause a ~0.019 mm error. OTOH a pixel is one 72th of in inch so the range of error form pixel snapping is 0-2*0.35 mm which is safely above what OP is seeing. – joojaa May 12 '17 at 10:49
  • @joojaa Ah, thanks, didn't know that. I changed it to 0.001 and it changed, but as soon as I closed and reopened Illustrator it was back to 0.028. Maybe his issue was because of the pixel grid + precision in pathfinder. – WELZ May 12 '17 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.