1

I need a text to adapt to a box but the second word is getting under the other like it was a paragraph way over its needed.

Below the example of the original lay out Vs. the result after resizing the symbol: THE PHOTOS ARE SCREENSHOTS (NOT REAL SIZE NOT REAL SCALE)

I don't even understand why the second word is going under the first is theres still plenty space, On image 3 you can look that the text field its not even near before/after the resize .

Original layout Resizing result Text space

2

You need to set the text to "Auto" rather than "Fixed":

Auto

  • Nothing :( ... i wouldn't like to convert every text with this problem – Cristobal Lemoine Nov 17 '16 at 18:22
  • This resets the bounding box to fit the text, but resizing it still behaves the same way as in OP's screenshot. Can you elaborate? – Charlie Schliesser Oct 4 '18 at 16:48
0

I don't know of a way to resize text in symbols, please correct me if there is a way in the updated versions.

The solution to this is converting the text layer to outlines. (Right click on the text > convert to outlines). Note that you can't edit the text after you've done this, so what you can do is duplicate it before you convert it, and keep the second layer hidden so you can edit text if you need to and then just convert it again.

0

If setting the symbol's text field's width to "Fixed" isn't working for you, try playing with the text field's "Resizing" options. "Float in space" and "Pin to corner" should make it so that the text field isn't resized when the symbol is resized, while with "Resize object", the margins will be respected, so the text field shouldn't be resized as dramatically when resizing the symbol.

0

Try also fixing the text width so the left and right padding is equal within the bounding box (i.e. 24 px on either side). That way, the text will wrap when it should wrap.

enter image description here

I've experienced more stable designs with fixed-width text boxes than auto (sometimes when you resize an item with auto-width text it will cause unwanted wrapping).

0

It's because your resized rather than scaled. Use the "scale" function on the top of your toolbar. That should normally solve your problem :) Scale

  • It's not available for symbols – DataGreed Jun 3 '17 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.