2

enter image description here

I'm having problems trying to fill in some color in a halftone effect. My process is that I create a gradient, go to the effects menu then select color halftone from pixelate. Then I expand then image trace. After tracing I select ignore white, then trace, then I expand again.

I want to fill the effect with a certain color, but this isn't the result I get.

Am I missing a step, or is there a better way?

  • Never mind, after it's all done I used Live Paint. – LittleKidLover Nov 23 '16 at 4:48
  • 2
    If you have found a solution to your own question, please consider adding the solution as an answer and check it 'accepted'. That way, later visitors with the same issue will profit from your experience. Thanks! – Vincent Nov 23 '16 at 11:35
0

Setting "Ignore white" on image trace doesn't prevent those paths from being created, it simply created paths with no fill, so when you're setting a fill after expanding your image trace you're filling the entire area, including these invisible paths.

Simple workaround to delete the invisible (or white if you don't check "ignore white") paths after expanding your image trace;

  1. Double click the expanded image trace to enter isolation mode
    (This is only to prevent you from accidentally deleting anything else, so if there is nothing else in your document this isn't necessary)
  2. Select one of the filled paths with the Direct Selection Tool
  3. Go to Select → Same → Fill Color (or use the button in the top bar)
  4. Cut
  5. Select All (i.e. all the invisible non-filled paths)
  6. Delete
  7. Paste in Place (SHIFT+cmd+V)

You could just select the invisible paths and delete but it's easier to select something you can see and the cut and paste in place is only two key combinations so it's easy enough.

  • I just now noticed this and I might of answered this somewhere else. I did what the process that was asked in the question and then used live paint then expanded it, then choosing a color from swatches or however you do it. Your answer works as well. – LittleKidLover Dec 7 '16 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.