3

I am trying to add kerning data to my font. I have manually kerned each letter pair in the “Kern Pair Closeup” window, like this:

kern pair closeup

But these settings do not seem to export once the TTF is generated. Why is this?

Here is how things look like from the metadata dialog:

metadata

And here is the data dialog:

data

5

You somehow managed to leave the feature field of your lookup empty:

Problem highlighted

If you change this field’s content to kern, everything should be working as expected.

Explanation: Lookups are controlled with features associated to them. Some of those features are activated by default in most programs and contexts (e.g., kern is activated by default for horizontal text, but not activated for vertical text), others have to be activated by the user (e.g., stylistic sets). Therefore, you want to associate almost every lookup with a feature, otherwise you will not see any effect. (The only exception are lookups that are activated by other lookups.)

  • This is OpenType kerning – doesn't FontForge support a plain kern table, then? Especially since OP does not use the advanced options (such as kerning groups), but rather sticks to "old school" one letter pair at a time kerning. – usr2564301 Nov 30 '16 at 9:55
  • @RadLexus: doesn't FontForge support a plain kern table, then? – I am not aware of it. But then, this is strictly speaking how kerning is stored in FontForge, which does not have to be identical to what it eventually exports. – Wrzlprmft Nov 30 '16 at 10:02
  • @Wrzlprmft Thank you! I was able to select horizontal kerning (kern) from the circled feature menu, but I see no visible change in the metrics window (ctrl + k) or any newly exported TTF/OTF font file when I type in text (AV, for example). Kern Pair Closeup and the Metrics windows both reference "Pairwise Positioning (kerning) in Latin Lookup 01," yet still, only the Kern Pair Closeup window displays the kerning properly. Am I missing a step here? – John Ash Dec 1 '16 at 2:36
  • @JohnAsh: Sorry, I am out of ideas then. I can only suggest that you double-check everything, or create a new font from scratch and compare. The only thing that I can say is that the kerning should really show up in the metrics window. If it doesn’t there is no need to bother looking at exports. – Wrzlprmft Dec 1 '16 at 8:59
  • This has shed light on something else. I was finding that, in the metrics window, kerning wasn't being applied until I click between the two characters involved. Moreover, when I edit the text, the kerning would disappear again. It turned out that this was being triggered by the same mistake in how the lookup is set up. Lesson learned: If you get this issue in the metrics window, check the lookup settings. If you don't, then the kerning won't take effect when you deploy the font. – Stewart Dec 24 '18 at 1:59
1

YEEEES, finally here is the solution, because it was not a problem of empty field for me :

  • When you generate the font, you have to tick the 'OpenType old kernel mode' option in the Options dialog. So : click generate, click "option", check that "old mode", generate and that's it ^^ Now it works with LibreOffice and Unity3D, perfect.

Thanks to Dave Crossland on the page http://fontforge.10959.n7.nabble.com/fontforge-users-A-few-problems-kern-pairing-doesn-t-seem-to-work-Windows-7-td14407.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.