I noticed that in Adobe CS6 there is still no way to import *.svg files into Adobe InDesign and Photoshop.

Now I want to use a lot of svg's from "TheNounProject", due to their high quality and visual consistency. But part of it is also to "play around" with them, basically to find the most suitable image for the accompanying text. To do that I already have to download a lot of svg's that I might not use.

I don't want to also have to manually (1 by 1) export all of them to *.eps (assuming that's the only way) when I later won't use them. And: It seems that there is still no import option for SVG in InDesign and while there is the "SCAND SVG Kit 1.0.8 for Adobe Creative Suite", it doesn't work with CS6 (I tried it).

Plus it somehow beats the purpose of the open and free SVG format when I have to pay $99 for a licence of something that should be included or possible with another software. The publications I use "TheNounProject" icons for are "non-profit" anyways.

Is there any other work-around? Or is there an easy way to add batch-support for InkScape?

(A way that - if it's by commandline - does make it easy for me as a non-IT/math-nerd to precisely understand (where and how) the batch processing script will run on those files.)

I also posted this question on Quora. (Under the title "Why does Adobe InDesign still not support the placement (import) of SVG's (in CS6)?", I can't use more than two hyperlinks here.)


For Windows non-command line, check out InkscapeBatch. I don't have access to a Windows machine to test it out, but it seems like it would do what you need to do.

  • Thanks, that basically looks great! However, upon actually trying it (v.1.30) out I get this error message: dl.dropbox.com/u/16751/inkscape-and-batch.jpg, even though I have installed v.0.48.2 of Inkscape! – grunwald2.0 Jun 26 '12 at 14:22
  • @grunwald2.0, are you able to do the batch conversion despite the error message? What about if you roll back your Inkscape installation to the .47 version? Again, sorry I don't have access to a Windows machine, so I can't help you much with this error message. – Ananda Mahto Jun 26 '12 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.