Illustrator's anti-aliasing is really rough comparing to Photoshop or After Effects. It's strange, because my tries to search this problem always bring me to answers like "It is normal, that's how your monitor render raster", when it is definitely not normal.

For an experiment I made a circle in Illustrator, Photoshop and After Effects (All are the latest version, CC 2017) and compared. While Illustrator's AA was rough (limited opacity values), Photoshop and After Effects had really noticeable difference. I was really amazed how After Effects did it: AA was really smooth and looked like it using all the opacity values for AA.

I tried to increase document's DPI, PPI, but nothing changed. It happens both in pixel preview, and on exported images (tried to export in all possible ways, like deprecated web-export, the new Export for Screens option, and the regular export).

This issue bothers me because the roughness on an exported image is noticeable even from a distance. I will be really glad if you could help me.

5 Answers 5


Why and how? I have no idea.

Just one tip. Export your image, let us say at 200 or 300% and resample it on Photoshop.

  • 1
    That works yes but is by far not the best thing you can do.
    – joojaa
    Dec 4, 2016 at 8:02

Indeed. Thing is computer graphics is a parallel invention. Today you can see two distinct groups of graphics programmers. The other builds on a tradition from GUI programming, this group is heavily entrenched in 2D graphics. For their merit they did use their brightest people to solve the color reproduction problem that is actually a insanely complicated issue.

The second group comes from a very academic background that actually tried to tackle 3D graphics and motion graphics. This group of people had a much more challenging task and actually needed to do much more thinking about how to approach their work. This group has a totally different take on how anti aliasing works.

Since AE is strongly affected by the later culture its not surprising that their rendering engine is more sophisticated. See most of the glitches and rendering errors exhibited by main line 2D rasterizer (Including one in chrome, safari, ie, QT and firefox) have already been solved in 1990s. One quite pronounced problem is that quite many 2D programmers seem to think that box filtering is actually a good strategy. And many systems even today do not account for the screen non linearity in the internal calculation.

We can do better? Or then not. Signal processing theory tells us that we have a choice between ringing and blurring. It is clear that you prefer blurring but that does not mean its a universally true preference. Personally I prefer the look produced by a Lanczos filter, but many people find it disturbing. This is also the reason why illustrator is so sharp, see for text the sharpness is more important than anything else, since graphics designing is much about text it makes some sense to do this.

Ok, so back to the question what can you do? Well you can render outside illustrator, but then you get no feedback on screen. There is also a bit of a curious development in Illustrator itself. See it has 3 different ways to render the picture. Hinted render (that you despise), art optimized (That uses 4x4 box filter non corrected) and a openGL render.

Now the openGL renderer is actually better that the 2 other options, because 3D accelerator programmers represent the other category and hardware manufacturers handle some of the things for you. Only adobe has forgotten to actually implement a save routine that uses this renderer. It has many advantages, including the fact that it fixes many of the traditional render bugs associated with vector engines. Presumably a few versions from now as aside effect this will be fixed. You can however improve the art optimized by using a linear working space and then enabling color correction go convert that to sRGB this makes the image much better. It still has 4x4 levels of alpha but its now distributed better so results are where it counts more. Also you can aa twice with are optimized as a rasterization effect on the layer at extra size then a second time down sampled.

See also:


Just change from CMYK to RGB! This is the actual fix. It's a colour space issue.


I found a solution: I simply just opened AI project in Photoshop, set desired resolution. And it looked a lot better that way. Looks like I'm always going to use this method.

Thank you all for your detailed answers.


Your problem might be GPU previews. They enabled it a couple of versions ago and it made my previews crunchy/aliased so I went on a quest to find out how to disable it.

So check to see if you have GPU previews turned on. If your document says something like (RGB/GPU Preview) hit cmd/ctrl-e to toggle CPU previewing. This will likely make it look a lot better. If it does, you can disable GPU previews (otherwise it'll be back on when you open AI again). Go to prefs > GPU Performance and uncheck GPU performance (there's also a little rocket icon you can click to take you right to the preference, it's in the menu bar with the AI logo).

If you're working on complex documents, this might slow you down, but I haven't noticed anything slowing down on my workstation. And besides, if you can't properly see what you're working on, what's the point of it being faster anyway?

  • wow, I'd really like to know why GPU rendering makes anti-aliasing look so crappy, because switching to CPU rendering totally fixed the issue for me. Mar 18, 2018 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.