0

I am transalting a 15-page brochure to 23 languages and I keep running into obstacles. While I finally managed to get data to merge properly I seem to get another problem which is messed up text after the merge. The special symbols for every language are gone, instead I get some messed up strings of unknown characters. If I paste manually everything is fine and dandy. Any suggestions?

  • You will have to create specific style per language on account that not all fonts are encoded the same way, if the fonts you use do not have the language you need you are going to run into problems. I could suggest you set one document per language and take out the hassle of of worrying about a single document in multiple languages. – Sewesakehout Jun 6 '17 at 9:52
1

U can try in excel.. safe as txt file UTF-16 en try merging from that.

  • What do you use excel for if you are saving the file in .txt? Can you re-write in a way that is more clear? We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed. – Luciano Oct 5 '17 at 12:20
0

See the source file encoding. It may not be appropriate so InDesign will not translate characters correctly.

  • How do I check that and - most importantly - how do I repair that? I'm using google docs, as the data source I get from my translators is based on it. I export using .tsv format, as .csv is not viable for me. – Whytek Dec 7 '16 at 22:46
  • @Whytek I don't know if this is still an issue for you, but the most reliable way I have found is to open the TSV (or CSV—that can be tab-separated as well) file in a good, advanced text editor (I use Coda; TextWrangler, Notepad++, Open/Neo/LibreOffice and many others should do as well—Excel will not work) and convert it to UTF-16. Make sure you convert (not reinterpret), and make sure it's UTF-16, not UTF-8. When you select your data source in InDesign, check the “Show options” checkbox and in the resulting dialog choose “Unicode” as the encoding and “Tab” as the delimiter. – Janus Bahs Jacquet May 8 '17 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.