5

This seems like something that should be easy to do... but I'm stuck, today, needing to use Illustrator. And desperately want to turn off ALL hyphenation.

How do I do this? There's no switch, seemingly, to do it.

And I don't fancy entering the entire dictionary into the exceptions panel in preferences.

5
  • 4
    Window > Type > Paragraph and at the bottom of the window Hyphenate (checkbox). All new text boxes you create will use this setting (unless overwritten by a style), though when you make a new document, it defaults to hyphenate again. Another way would be to have it in your Paragraph Style: Window > Type > Paragraph styleParagraph style options > Hyphenation > Hyphenate (checkbox).
    – Joonas
    Dec 9, 2016 at 8:55
  • 1
    @Joonas that should probably be an aswer ;)
    – joojaa
    Dec 9, 2016 at 8:57
  • @joonas, I completely agree with joojaa, that's an answer! Which begs a question... why is it there, and not in the preferences?
    – Confused
    Dec 9, 2016 at 9:17
  • @joojaa, is there somewhere I can ask about other's experiences with the new Illustrator? It's mind bendingly stuttery and laggy for me, on a crisp new Macbook Pro. I have VERY low expectations for Illustrator performance on a Mac, but it's getting ridiculous, and far beyond bothersome. Have switched to using Affinity Designer, despite it only being half baked, at best... stuck with Macbook Pro, and no Bootcamp, for a few days... and REALLY missing CorelDraw for quick things I need to show and explain. INFURIATION at all time highs.
    – Confused
    Dec 9, 2016 at 9:21
  • @Confused, the Hyphenate option has lived in the paragraph panel going back to, at least, the original Creative Suite. If your Illustrator is running unexpectedly slow, try un-ticking the GPU performance box in Illustrator preferences > GPU Performance. You can find a list of system requirements for optimal GPU Performance here. Dec 9, 2016 at 16:06

1 Answer 1

3

Open up the Paragraph Menu. Click the 3 Horizontal Lines (Menu) on the right hand side, then click on Hyphenation.

Unclick the Hyphenation option. Done.

Alternatively you can also set the Words Longer Than option to something large like 15 letters, and nothing will be hyphenated.

2
  • 3
    Welcome Neil! Thanks for supplying an answer. Please don't litter answers with irrelevant links - especially given your chosen username. If you wish to promote your web site, you can do that in your profile, not in questions or answers.
    – Scott
    Jun 14, 2022 at 23:35
  • 1
    Hi Neil. For more information on self-promotion on the Stack Exchange Network, please see this help center page.
    – PieBie
    Jun 15, 2022 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.