0

Okay, so let's give a example of what I want. We got a white ball with black lines. I want for example a flag in it. When I drag or paste the image of that flag in it, it goes up to the whole page and covers the other.

How do I prevent this and have a flag into a ball with eyes on the flag. I searched it up and found it nowhere. I searched really good.

Picture without flag Normal Picture without flag

Picture with flag but it stacks up :( enter image description here

Other one Solution didn't work.

2
  • 1
    Can you add a screenshot that shows the problem? That would make it easier to answer this question. Dec 20, 2016 at 16:32
  • I have just added it for you :)
    – Rootel
    Dec 20, 2016 at 19:55

1 Answer 1

3
  1. When you paste/drag things in, they keep their original size in pixels. You usually have to scale them (Layer>Scale layer or the Scale tool)(and very often Rotate them as well...) to make them fit.

  2. If you want to cover a ball with a flag (which is likely flat when you import it...) you have to distort the flag. For this there is Filters>Map>Map object and its "Sphere" option.This filter maps the whole layer to a sphere, so you likely have to put your flag in a larger layer that surrounds it with transparency. Then if you have everything right adding the flag layer over the ball will make the flag appear to be part of the ball.

After the screenshot: no, you can't do that directly, but it is not hard either:

  • After the paste, make the pasted item a new layer (*Layer>To new layerù or Ctrl-Shift-N)
  • Adjust the position of that new layer with the Move tool (the pasted item is always pasted centered in the selection)
  • Invert the selection (Select>Invert)
  • Edit>Clear or [delete] to delete everything outside the initial selection.

Note that technically, the selection is not necessary when you paste (except to roughly position the flag). The following workflow would have worked just as well:

  • import the flag a new layer (drag from another opened image, File>Open as layers, or Edit>Copy/Layer>To new layer as above
  • Make the previous layer active while you create the selection (color select or else)
  • Select>Invert
  • Make the flag layer active, make sure it has an alpha channel (Layer>Transparency>Add alpha channel) and Edit>Clear
2
  • @rootel updated my explanation
    – xenoid
    Dec 20, 2016 at 20:12
  • It seems that the flag layer is missing an alpha channel (which means that you didn't paste it, but dragged it or opened it). Use Layer>Transparency>Add alpha channel after adding it to the image (its name in the Layers list should lose the boldface).
    – xenoid
    Dec 21, 2016 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.