0

I am unable to use the "paste in front" function. It does not matter if I use the keyboard command or go to edit>paste in front. No matter what I do, it pastes the object in its original location. I have tried to change between Global and Artboard rulers as per a previous suggestion but it did not help. I have read a ton of similar posts but none of the suggestions have worked.

I am getting very frustrated as I've used this function many times in the past and never had an issues until today and this issue is stalling a big project. Anyone have

  • 1
    Could it be that what ever is in front, is on a different layer above the one you're trying to paste. – Joonas Jan 10 '17 at 21:45
  • Are you just copying something then pasting in front? That will just put a duplicate exactly on top of the original. – Scott Jan 10 '17 at 22:14
2

It could be a number of things:

  1. Your drawing mode is set to Draw Behind. Check your tools panel to see if you see the following:

Tools panel set to Draw Behind

If you do, click the first option or press Shift-D until your mode changes to Draw Normal. If your tools panel is in one-column mode, the Shift-D command will still work, or look for the drawing mode at the bottom (you will only see one icon instead of all three).

  1. You are copying from a different layer and "Paste Remembers Layers" is checked. Look in your layers panel flyout menu and uncheck that option. The flyout menu is here:

Layers panel flyout menu

  1. You are copying and pasting onto a layer that is lower in the layer stack than the object you want to paste in front of. In the following example, if I try to cut the rectangle on layer 1 and paste in front on layer 1 or 2, it will still appear behind the ellipse.

Example with ellipse and rectangle with three layers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.