1

I am trying to get Illustrator to display my unicode font correctly (i.e. the way every other program is displaying it). I am currently using the Noto font, which I know can display all the characters I need.

The character I'm having an issue with is: ı̨ (dotless i with ogonek). As far as I can tell, this is created by combining U+0131 and U+0328.

This is what it looks like in Excel/Word/notepad/etc.

Illustrator only seems to output the dotless i (U+0131) without the ogonek. In the glyph panel, I can access the i with the dot and the ogonek (U+012f), but that is ultimately not the character I need.

Thank you for your help.

  • Sorry, I have same question - this came up in the AI scripting forums and I have found the same: it doesn't do combined characters but it does to single characters which are "pre-combined". – Silly-V Jan 18 '17 at 16:12
  • 1
    This might be a silly question, but is there a difference between the character that you need and U+012e? That is available in Noto Sans and they look the same to my ignorant, English eyes. :-) – Westside Jan 18 '17 at 16:25
  • @Chris +012e is a capital i+ogonek, OP wants a dotless i (which is just a lowercase i without the dot) – Cai Jan 18 '17 at 16:30
  • 1
    @rbhamjee is the problem only that they aren't combining correctly? I can't get them to combine but I can place both glyphs and negatively kern to get them to combine (like this) – Cai Jan 18 '17 at 16:38
  • @Cai When I try to adjust the kerning it doesn't actually change for me (I cannot seem to place the cursor between the i and the ogonek). I can make it look correct with tracking, but that doesn't really work when the character is used in a word. – rbhamjee Jan 18 '17 at 17:54
2

I honestly have no idea what's going on here. I can't get them to combine correctly from direct input at all but I could get them to combine correctly by pasting an ogonek directly before the dotless i... then two minutes later I try again and it doesn't work.

It's not ideal but as a workaround you can simply kern both glyphs to the correct position. Again, Illustrator is doing some weird things here; sometimes I can kern the glyphs (after inputing them directly after one another) with no problem and sometimes they're instantly combined and treated as a single character (although not visually)... So a workaround for the workaround; input the glyphs with a space between and kern from there.

So you input; ogonek + space + dotless i (the blue square is just the indicator for the space with "Show Hidden Characters" on):

enter image description here

And kern (I turned off "Show Hidden Characters" and placed a regular i+ogonek for reference):

enter image description here

Not ideal, but a workaround if you're really stuck and can't figure out a proper fix.

  • Following your exact workflow, I can create the character. Interestingly, if I try to paste that character into a word, it loses the ogonek. If use the workflow in the word, it will work, albeit with slightly tight spacing to the left. – rbhamjee Jan 18 '17 at 18:47
  • It's certainly strange, I can't even get consistent behaviour within Illustrator without the space between – Cai Jan 18 '17 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.