I have two AI CMYK files with a vector object in each. Both, when trying to save to PDF do not show in Summary any warnings. When trying to copy/paste from one AI file to another and then save the destination to PDF I get this "spot colors and transparency" warning. And this makes the print go wrong.

I tried : Select->Edit Colors->Convert to CMYK - did not help

Where did those spots and transparency came from if were not present in the origin files AND how to combine the two and get rid of the warning

Two examples are attached :


AI Version of FileA

  • attach the file or snapshot to inspect more in details – atek Jan 24 '17 at 5:07
  • In the File A there are spot colors. Pantone 252 C lilah and CutContour. Can you show us the ai file? – SZCZERZO KŁY Jan 24 '17 at 12:13
  • replaced FileB with AI version of FileA. In AI I see those as swatch colors. Also, CutContour is recognized properly by the plotter when the PDF is printed and for that I thought it has to be a swatch color – Louis Shraga Jan 24 '17 at 13:04
  • @SZCZERZO could you please also shortly teach me how you saw the spot colors in the file. thanks – Louis Shraga Jan 24 '17 at 23:27
  • @atek modified the question and attached the files – Louis Shraga Jan 24 '17 at 23:28

I'm using Acrobat Pro for basic output preview and editing.
For plotter the cutcontour need to be spot color (or to put it different, it need to be any color set to spot. The plotter should ignore it and not print this one). Are you sure you move (copy/paste) from CMYK to CMYK file? Ai should not show "spot colors and transparency" warning when you use file in the same range and profile.

  • @SZCZERZOFileA is originally CMYK, FileB is indeed orignially RGB which I converted to CMYK using "Edit Colors->Convert to CMYK" and also by setting "Document Color" to CMYK. And only after I converted the FileB I do copy from B to A. Is something wrong with my process ? – Louis Shraga Jan 25 '17 at 12:12
  • @LouisShraga if you work in newer Illustrator (CC) this could create some problems. But converting from RGB >CMYK should not create any spot colors. Try placing the file B directly into File A (file - place) and then remove unnecessary spot colors from swatches library. – SZCZERZO KŁY Jan 25 '17 at 13:01
  • "File->Place" did not help either. Eventually I found the solution. See my answer – Louis Shraga Jan 29 '17 at 21:24

I found the solution to "how to combine those files and git rid of the warning and its outcomes" : seems the problem was shadows and not the spot colors (the warning I got saving the PDF was dual, about both).Once I run "Flatten Shadows" - the warning disappeared and the printer recognized everything as expected

I dont have an explanation yet to how the problem got created at the first place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.