2

I'm laying out a composition in AI CS3, using a placed PSD file, and I'm getting not satisfactory results per the effects overlay quality. I hope you'll be able to help me out.

Image 1: This is the PSD file: 2 layers: (1) a blue background and (2) a piece of plastic with multiplied drop shadow.

Image 2: Now, I remove the background layer and save the PSD file that contains only the plastic frame with the Drop Shadow effect

Image 3: Then I place it into AI CS3 composition, which has its own background object (a rectangle filled with identical blue). The shadow result is mediocre, even though the entire chain seems to be CMYK all the way through.

PSD composition PSD place fileAI composition

What can I do to get the same results in AI?

7

Blend modes over transparency will not maintain appearance.

Basically the Multiply blend mode means nothing when you import it into Illustrator. Therefore you get a grey shadow which does not interact with anything behind it in Illustrator.

When you set a layer to a blend mode other than Normal in Photoshop, that layer calculates how the pixels should appear based on all pixels below that layer. When you place a Photoshop file in illustrator, you no longer have the ability to allow individual layers to interact with anything separately. The entire placed image becomes one object. And, while you certainly can adjust the blend mode of the entire placed image, you can not adjust blend modes of layers within the Photoshop file inside Illustrator. Or, in other words, there is no layer independence for placed Photoshop files within Illustrator.

If you want the dark, shadow, area to multiply with native illustrator objects, you need to create the shadow within Illustrator or place the shadow as a separate object so you can then adjust that object's blend options separately from the main subject.

Another option would be create the shadow which is set to the proper color and the blend mode set to "Normal" in Photoshop. Then place an image which does not rely on Photoshop blend modes for its appearance.

  • Yes, you're right, setting the Drop Shadow to desired color + Normal 100% did the trick, thanks. I just thought that the Adobe's self-praised integration went further than that, and that it's just a typical RTFM issue. Thanks. – Artur Jul 17 '12 at 14:14
1

Just found a easy solution for this. When placing a PSD file in Illustrator, and embedding it rather than linking it, choose Convert Layers to objects and Multiply blend mode will be there in Illustrator!

  • This didn't work for me. I ended up having to create two separate PSD files - one for shadows (multiply), and one for the object without shadows (normal), and then stack the object PSD over the shadows PSD and group them after specifying the multiply blend mode for the shadows one. Any idea why it didn't work? [Used CS6, CC'18 also didn't work except it didn't ask if I wanted to convert layers to objects, it did it automatically but didn't set the blend mode] – Mentalist Nov 10 '17 at 2:28
0

It's actually a very simple answer: You just need a transparent shadow. Isolate the shadow on a layer in Photoshop, apply the transparency, and give it some grain or whatever you prefer to add some realism. You'll have much better control over it than you would playing around with drop shadows in Illustrator.

Illustrator can handle transparency but not effects internal to the Photoshop file. Not changing the behavior of your art outside the application is a good thing, in my opinion. Otherwise, you could end up with some very unpredictable results when placing images.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.