6

In Windows, the standard scroll-wheel zoom key is Ctrl. Pretty much everything follows this standard, including all web browsers, Word, Explorer, even Adobe Reader. Except Adobe Creative Cloud software (Illustrator, Photoshop, InDesign, etc.). It uses the Alt key instead.

This drives me nuts. Switching between all of these programs has my fingers in a frazzle. I keep using the wrong key in the wrong program.

To make matters worse, I also use Macintosh PCs on a daily basis (school vs home), and they use Alt to zoom. I could deal with the differences between MacOS and Windows just fine, except Adobe CC on Windows has to come in and throw a spanner in the works.

Is there a way to scroll-wheel zoom with Ctrl in Adobe CC software on Windows, instead of Alt?

1
  • You could download AutoHotKey and add theese lines to your script: ; Map Ctrl+Wheel to do Alt+Wheel for Adobe Illustrator to act like Affinity #IfWinActive ahk_class illustrator ^WheelUp::!WheelUp ^WheelDown::!WheelDown
    – agiopnl
    Sep 13, 2018 at 13:57

5 Answers 5

4

The only way I think you can do this is through Autohotkey. It’s a bit of work, but worth the effort. You have to first install Autohotkey. And then run a script on your background. For me it is always running on my background.

For a guide to Autohotkey look here.

Make a script with this code. It does the following: When you are working in Indesign, the middle mouse button lets you move the page, as if you were pressing space and left mouse button. It also changes Ctrl scroll to Alt scroll.

#IfWinActive ahk_class indesign
;Middle mouse button moves the page
    MButton::
    Send {Space Down}{LButton Down}
    Keywait, MButton
    Send {LButton Up}{Space Up}
    Return
;Map Ctrl+Wheel to do Alt+Wheel
    ^WheelUp::!WheelUp
    ^WheelDown::!WheelDown
#IfWinActive
1
  • For v2: #HotIf WinActive("ahk_class indesign") ;Middle mouse button moves the page MButton:: { Send "{Space Down}{LButton Down}" Keywait "MButton" Send "{LButton Up}{Space Up}" Return } ;Map Ctrl+Wheel to do Alt+Wheel ^WheelUp::!WheelUp ^WheelDown::!WheelDown #HotIf
    – jfacemyer
    Aug 5, 2022 at 16:29
3

I believe you got 3 options:

  1. There's the Zoom with scroll wheel, so you can zoom just by using the scroll wheel.
  2. There's the cmd+space + mouse click zooming (alt+space for zooming out).
  3. ...and the same thing as the previous method, except instead of a mouse click, you mouse drag sideways with the mouse while pressing down those same modifier keys. Also works if you switch to the zoom tool (Z), if you're not a fan of modifier keys at all
3
  • I have since discovered that Adobe calls #3 "Animated Zoom" in Illustrator and "Scrubby zoom" in Photoshop. There is an option in the Illustrator Settings under "GPU Performance" (of all places) to disable it. For Googlers.
    – user53083
    Mar 16, 2017 at 14:38
  • What is Cmd+Space in Windows (as original question asks about)?
    – NetMage
    Jul 31, 2019 at 23:32
  • @NetMage, that would be: Ctrl+Space (typically any shortcut with Cmd translates to Ctrl on Windows)
    – Joonas
    Aug 1, 2019 at 8:34
2

I solved the problem. Edit > Preferences > Tools > Check the item "Zoom with Scroll Wheel" Now you changed Alt to CTRL to zoom in/out. That's it. version: Photoshop CC 2019

2
  • This worked for me on Photoshop! My only problem, now, is with with Premiere! :- ( Jun 7, 2022 at 19:08
  • This is the answer for me Dec 9, 2023 at 9:16
0

I too am facing this issue. The problem is my computer admin wont allow me to install AutoHotkey. Is there another way to script and solve the issue. I believe scripting can do wonders. PLease help !

New contributor
akshay korlekar is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
-1

If you go to 'Edit → Keyboard shortcuts' you can set your own keys.

1
  • That works for regular shortcuts. But Alt+Mouse Wheel is not a regular shortcut. It's not listed there (I should have mentioned this in the question), and I was looking for an alternative way. I'm not too hopeful, to be honest.
    – user53083
    Feb 10, 2017 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.