0

I always bump into this problem of distorting a logo when I shrink it in illustrator. I have expanded the object and converted all outlines.

I tried 'simplify' and 'clean up' the anchor points, and I was holding down shift key when I resize the object.

I've looked at a few online forums and no one seem to ask this question so I'm not sure if I'm just doing anything wrong.

Thanks.

  • 1
    Can you post what the distortion your experiencing looks like? – Ryan Jul 20 '12 at 18:58
  • Did you select all points when resizing? If it's expanded and all outlines converted it shouldn't distort. – kamalo Jul 20 '12 at 19:04
12

Things to check....

  • Is Align to Pixel Grid checked on the Transform Panel when the artwork is selected? If so.. turn it off unless you are create web images where it may be beneficial.

  • Is Scale Strokes and Effects Checked? (Transform Panel or Preferences in CS6, Only preferences in previous versions) If so, you may want to uncheck that option before scaling.

Beyond this, you'll need to define "Distort" far more than you have.

  • The strokes not scaling down was my first thought. I wasn't aware there was a way to have them stay relative to the object size. Thanks for the info. – John Feb 27 '14 at 14:25
3

Using Illustrator - select the entire vector image and then go to Object - Paths - Outline Paths. Once you have done this, you can resize any vector image as small as you need it. This is an additional step past converting all outlines.

2

In addition to Scott's answer (which contains good things to check), Illustrator only has a certain internal resolution. That means if you're editing things at a very small size, you may see some rounding, which will bump points around.

If that's the reason why, you'll need to edit at a larger size.

2

I had the same issue when designing icons!

To get rid of distortion, go to: Transform Panel and click on the additional preferences button (that button in the top right of the Transform panel with additional options) and make sure "Align New Objects to Pixel Grid" is NOT CHECKED.

That way, when you combine shapes together or move stuff around, it doesn't distort them to the pixel grid. Alternatively, just make sure "Align to pixel grid" in the Transform panel is unselected too before scaling and it should be all good!

1

In my case, I had drawn a larger artwork than artboard. So when I wanted to scale it down to fit it inside the artboard, its strokes became bold.

I went to Edit > Preferences > General, then turned Scale Strokes and Effects on. Now the strokes are normal.

1

I think I know what might be the issue.

Select the object that you're trying to scale and then go to Object > Flatten Transparency... and you should be able to solve it.

Lemme know if this works!

  • Hi Manav Dhiman, welcome to GDSE and thanks for your answer. If you want to know more about the site, please see the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – PieBie Jun 30 '15 at 11:48
  • 1
    @Manav Dhirman - I created an account specifically to thank you! Good work - your fix resolved my problem. Any ideas what's going on here/why this works?? – user51579 Sep 27 '15 at 17:15
  • Manav - "I think I know what might be the issue. Select the object that you're trying to scale and then go to Object > Flatten Transparency... and you should be able to solve it." That worked for me, the logo file I had contained an element with opacity reduced. Thanks so much! www.RajaSandhu.com – user61130 Feb 23 '16 at 15:10
  • This fixed it for me and was the only thing that worked. I tried un-checking the pixel grid stuff, i tried the transform precision and, although this option does heavily mess with the paths, I can fix the original to how i want it to look and then convert it using this technique. Thanks Manav! – Partack Apr 5 '18 at 10:06
0

If nothing works out, try making a compound path of the vector. Like if its divided in pieces then select each component individually. You can find it in the object menu. Once its all done, select the entire vector and make it a compound path. Worked for me.

0

You must have the box checkd : in Transformation panel ---> Scale strokes and efects and uncheck Align to pixel grid. And it works.

  • 2
    Hi HAPPY, welcome to GDSE. Please do not post answers if they do not offer any new information. The solution you give has already been suggested in other answers. If you have any questions, please see the help center or ping one of us in chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Feb 13 '15 at 9:59
0

Here's an issue that caught me. I needed to set a higher precision value under pathfinder options. Go to pathfinder and under the more option select pathfinder options and increase the precision value to the highest setting (small number). This example shows the highest value.

Pathfinder Window

Pathfinder Options

protected by Community Feb 23 '16 at 15:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.