1

I have created four guides by dragging out from the rulers, however I cannot see them in my layers panel. The layer they are on does show cues of a selection being made, however. I want to move my guides onto another layer, so I can quickly (un)hide them.

Is there any setting I missed that makes them show up? Or am I having the wrong idea here?

layers panel showing that something on layer 1 is selected, but no guides

2

You appear to have the wrong idea about the way InDesign works with guides. Some other good answers here, but to put everything in perspective so you see how this works:

  • any layer can contain guides in InDesign
  • hidden layers can contain guides, but these will be invisible
  • all you guides from all your visible layers can be hidden/shown via CTRL+;
  • if you still need to move guides between layers, hit CTRL+ALT+G to select all guides, CTRL+X to cut, then paste to another layer (note this only selects unlocked guides from visible layers only)
  • read the official docs at Adobe for more info on this, locking guides, smart guides, stacking order, etc
  • I see. Thanks for the info :) Can guides also be part of a group? – CrazyQwert Mar 6 '17 at 11:20
  • No. Guides do not group with objects. You can however add guides to different layers. You should have plenty of info here to do a bit of experimenting yourself? :) If you feel this answer helped in any way, try clicking the up arrow and/or the check icon next to my answer above. Thanks – Lucian Mar 6 '17 at 11:37
  • Votes do not go through unless you have earned a certain amount of points. I have yet to reach that level. – CrazyQwert Mar 7 '17 at 9:51
  • Yes, I could experiment for myself, however I was not on my PC where I have the program installed when writing this comment. Also I thought it might be useful for others, that may have the same question, so they do not have to experience themselves and thus save time, however I can see how stealing your time is annoying. I am sorry if it might have bothered you. – CrazyQwert Mar 7 '17 at 9:54
  • No worries. We are giving away some of our own free time by answering here, but can't write books for each question. Normally some trial and error is expected from the OP's as personal experience beats a written article. If there's anything else we can help you with here let us know. – Lucian Mar 7 '17 at 10:30
3

Quickly hiding guides is called "pressing W". From InDesign point of view you either working on a document and need to see guides, text boxes etc. or you want to see how finished page looks like. There is no in-between because, frankly, there is no reason to not see only guides.

  • The reason I was using guides in the first place is, that indesign apparently does not allow objects snapping together. Now I do have specific guides that are only there for a certain object-group. When I want to move this object group I do want to move these guides also. However I do not want to select every other guide, so I thought it might be easier to have them on a certain layer which would make selecting the object group and the accompanying guides easier. – CrazyQwert Mar 6 '17 at 11:25
  • Have you tried using guides only on page (not the one that fall to the bleed) and change them to "Liquid". Or change color and lock certain guides that are not object specific. – SZCZERZO KŁY Mar 6 '17 at 11:42
3

Guides do not appear as elements in INDD Layers panel like they do in AI.

If you just want to quickly hide/unhide them, you can use hotkey CTRL(CMD)+;
(Note: Shortcut may vary according to regional preferences or keybords)

If you want to place them on a new layer, use hotkey CTRL(CMD)+ALT+G to select all guides (make sure they aren't locked first). Then simply Cut and Paste on a new layer.

  • ctrl+$? Ctrl-4 is 400% zoom. ctrl-; hide guides but all of them, margins slug bleed included. – SZCZERZO KŁY Mar 3 '17 at 9:06
  • Hope i'm not wrong but there is no default CTRL+$ shortcut. That's why i edited Vinny's post. – Lucian Mar 3 '17 at 9:10
  • Ah well... Are you Mac users? As a Windows user, default hotkey seems to be CTRL + $. I personally based my custom shortcut preferences on QXP (hotkey F7)... I'm so old fashion ^^ EDIT: oh I think I got it... I use a AZERTY keybord... – Vinny Mar 3 '17 at 9:15
  • Never used a Mac and never bothered to change default shortcuts, which in my CS6 and CC copies is CTRL+; for show/hide guides. – Lucian Mar 3 '17 at 9:21
  • Honestly didnt know what an AZERTY keyboard was until just NOW :) so maybe to keep your answer valid for most users as per Adobe official docs, just leave the default shortcut? Just a suggestion – Lucian Mar 3 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.