3

I'm creating a magazine in Indesign and have pdf ads that I imported and placed all throughout the magazine. The pdf ads are crisp and clear in their original format, but when I place them in Indesign, they're super blurry. I tried converting the pdf ads to a bunch of different formats (jpeg's, png's, etc), then placed them in Indesign. This reduces some of the blurriness, but when printed, they are still unreadable.

Just to show you what I mean, here's an ss of a pdf in Adobe Reader:

pdf in adobe reader

and here's how it appears in InDesign:

InDesign

Both are at 100%.

Do you have any idea why I'm having this problem, and how I might be able to fix it?

  • Just adding some relevant search terms: this happens with any type of placed file, not just pdf and raster images (also eps, ai, psd, etc). It also sometimes shows more as blocky pixelation than blurring. – user56reinstatemonica8 Jan 11 '13 at 10:20
9

Make certain View > Display Performance is set to Highest Quality.

There is also an Object Level display, Object > Display Performance.

The View Display performance should, by default, override the object level setting.

This setting allows imported images to be displayed at a lower quality in order to speed up things like panning, zooming, and general screen redraw. However, upon output the imported images will be output at their proper resolution. In other words, the display performance settings have nothing to with document output, only the document preview.

  • Thanks for your response! I changed View -> Display Performance to Highest Quality, but when I go to Options -> Display Performance, all the options are grayed out. As of now, I don't notice any difference in the display. – mdegges Jul 25 '12 at 23:21
  • Click an image and then choose Object > Display Performance. What version of Indesign? Also check Preferences > Display performance and adjust if needed. – Scott Jul 25 '12 at 23:24
  • Wow, thank you! This worked great! (I had forgotten to select the image.) Thanks for helping me avert a total disaster :) – mdegges Jul 25 '12 at 23:27
4

thebodzio's and Scott's answers are correct, but I wouldn't necessarily recommend the same thing.

If and when you are working with hundreds of pages, it can really pay off to have it set as Typical display. If you feel like highest setting has no effect in the performance, then go for it, but personally I keep it set as 'typical display' at all times. I don't need to see the images all crisp and clear all the time.

What I use myself is a hotkey for Overprint preview: Cmd + Alt + Shift + Y - This hotkey toggles the overprint preview on and off, which among other things, makes images show up all crisp and clear.



Overprint preview hotkey accompanied with the hotkey for preview: W, are both ones that rank really high as my 'most used hotkeys in indesign'.

  • 2
    True... but it's important to know how the display settings work and where they are. That was all I meant by my answer. – Scott Jul 26 '12 at 1:47
  • …and "Display Performance" presets are also accessible from "View" menu, where they're applied to the whole document. – thebodzio Jul 26 '12 at 8:30
  • @thebodzio I'm not sure where you're getting at? Or do you perhaps mean that it applies to all documents? Either way, it doesn't matter since overprint preview is applied to the (whole) current document you're on (not just a single page), and since the point that I'm making about using it is to basically only use it when you need it for the sake of performance, it's only good that it doesn't affect every single open document. – Joonas Jul 26 '12 at 9:43
  • @Joonas yes, I got your point, I agree. I simply wanted to emphasize that there are two places where "Display Performance" can be set: first burried in the "Object" menu, second in "View". First controls display performance per object and second per document. That's it. – thebodzio Jul 26 '12 at 10:30
  • @thebodzio Alright. – Joonas Jul 26 '12 at 10:39
3

This is quite natural. Your PDF is all right – it's just that InDesign displays it that way. It does so because it needs to save some memory. What you see is only a “preview” of your PDF. You can change “quality” of this preview using e.g. one of “Object -> Display Performance” options. Try to change it to “High Quality” – you should be able to notice the difference easily in both quality and application “speed” ;). When exported to PDF or printed placed PDF should be as clear as the one on the first screenshot.

If I missed something in your question, please let me know – I want to delete this answer if it's irrelevant.

  • You're welcome :). I'm glad you solved your problem :). – thebodzio Jul 25 '12 at 23:41
1

Your PDF needs to be linked - you cannot copy and paste it into your ID document. Go to the "links" panel and make sure that the PDF resides on your computer/network, and you are linked to it. PDFs that are "unlinked" will be blurry.

protected by DᴀʀᴛʜVᴀᴅᴇʀ Sep 19 '16 at 13:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.