5

I have created a graphics in Photoshop CS6 and I saves it in .eps file format, and when I opened it in the Illustrator CC it is not recognizing any element more over if I zoom in the graphics is become blur. One more issue that when I open .eps file in Illustrator I found all my Photoshop layered are merged together.

I know Photoshop generate Raster image where as Illustrator generate Vector image, but Encapsulated PostScript files (.eps) is supported by both the tools so it should work?

So I want to know how to create/save a graphics in Photoshop and open it in Illustrator to do any other editing or changes.

Please Note: I'm just a beginner in this 2 tools.

  • 2
    EPS is not automatically a vector format. Just save as .psd and open that with Illustrator. – Scott Mar 11 '17 at 18:47
  • @wch1zpink has given you great instructions for ensuring that your layers are available in Illustrator, but I just want to point out that s/he is doing exactly what scott suggested; opening the native PSD file. There are very few situations that I run into where it isn't better to keep your original file in its native format when wanting to share it between photoshop and Illustrator. – magerber Mar 11 '17 at 19:53
3

When creating a Photoshop document, the initial image resolution is it important. Create the new document at 300 ppi image resolution. This will help the image from appearing blurry or pixelated when you zoom in.

enter image description here

When saving your new Photoshop document, be sure to enable the "Layers" option in the save dialog box. Save this file as a Photoshop .PSD document

enter image description here

In illustrator, go to menu item File/Open and choose your Photoshop document and enable the convert layers to objects option and the import hidden layers option if you want all objects from Photoshop visible in illustrator layers panel

enter image description here

Now your Photoshop document will be opened in illustrator, containing all of the layers from your Photoshop document

enter image description here

  • 1
    thanks, for such an explained answer, let me try it first. – Raunak Gupta Mar 12 '17 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.