0

This question already has an answer here:

I have a problem with a data merge. On several tutorials if they selected the CSV file, all the data loads up separately but when I select the CSV file, all data loads like this:

Data merge window

So I can't load them up separately. What I'm doing wrong?

My steps:

  1. make excel file with all my data
  2. save this file
  3. save the CSV file
  4. open InDesign document
  5. select data source
  6. then I see this...

marked as duplicate by Lucian, DᴀʀᴛʜVᴀᴅᴇʀ Mar 14 '17 at 17:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What does your csv file look like? – AndrewH Mar 14 '17 at 15:44
  • If the marked duplicate doesn't solve your issue please make an edit with further information and we can re-open your question. – DᴀʀᴛʜVᴀᴅᴇʀ Mar 14 '17 at 17:28
1

This is very typical.

Indesign expects your CSV fields to be comma separated.
BUT... depending on your regional settings, Excel might export CSV with a semicolon as separator. Errr... we are not (yet) all americans. This seems to be your case... not american right? ^^

Sooo... two solutions:

  1. Export Excel file as .txt file, tab separated. It works like a charm, this is what I would do.
  2. You really want to use CSV. (If you're a Mac user... I don't know). If you're a Windows user: open Control Panel > Regional Settings, Advanced parameters: change list separator to comma.

Hope that helps

  • On a Mac you could always just open the csv in a code editor and do a find-replace on the semi-colons. – PieBie Mar 14 '17 at 17:13
  • Sure. On a PC too. But that's an unnecessary extra step. I meant I don't know how to change regional settings on a Mac. Anyhow, I still advise using tabbed .txt – Vinny Mar 14 '17 at 17:45
  • that could be a dangerous step if your cell data contains a semi colon itself, +1 for tabs. This btw is the kind of format they use in the nordic countries, I heard, cells are split by semi colons while number decimal points are commas. – Silly-V Mar 14 '17 at 17:53
  • Thanks a lot Vinny! Yes, I'm not american, from Belgium here. The .txt file with tab separated works just fine! One more question Is CSV better to use than .txt? Or is this pretty much the same? – DigitalQuest_ Mar 15 '17 at 13:16
  • Good question. As far as I'm aware of, it's just a matter of separator. Commas or semicolons can be handled more easily in processes used for web development purposes, so in those cases, CSV is "better". Apart from that, I don't see much more differences. For InDesign data merge, none is better, both work as long as CSV is comma separated... – Vinny Mar 15 '17 at 15:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.