0

I need 3 circles aligned straight. I draw a circle using Ellipse tool. When I draw a second circle, I either draw it in the same layer or I draw it in a new layer.

The problem I am facing when I draw the circle in a same layer. I make a change to one circle, that change is also applied to the other circle (I don't want this). However, I can align the circles in a straight line.

If I draw the second circle on a new layer, I can make changes to both circles separately, however, now I cannot align these circles on a straight line, align option is grayed out.

4

You want a separate layer.

Highlight both layers in the Layers Panel by holding the Shift key down and clicking the layers. Then the align buttons will be available.

If you only have one layer highlighted, there's nothing to align to so the buttons will be disabled. You can't align a single layer to itself.

  • Thank you Scott! This helped. I was highlighting both layers, however, the alignment option was still grayed out. I learnt that there are two alignment options, one is path alignment, this is the one I was using to align multiple layers and it obviously won't work. In layers, there is layer alignment options which worked for me! – Bharat Nanwani Mar 27 '17 at 9:58
0

Edit: I misread the question. Please see Scott’s answer. If you want different colours or styling, you probably want two separate layers (there’s ways to get a single layer with different styling, but that’s a more complex solution).

It is possible to align shape objects within a single Photoshop layer.

The secret is having the Path Selection tool and the objects you’d like to align selected (if both those conditions aren’t met, the option to align objects will not be available).

Path selection tool

The align options are now available, and they work within the layer(s) and object(s) selected.

Align objects

And, the end result…

Aligned objects in Photoshop

  • The question states that as a single layer the issue is different appearances are needed, not that the alignment doesn't work. – Scott Mar 27 '17 at 0:53
  • Apologies for misreading it. I have up-voted your answer. – Marc Edwards Mar 27 '17 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.