3

I know It should be on the menu bar -> Extensions -> Render -> LaTeX Formula. But when I use inkscape on windows, there is no "LaTeX Formula" in the above path. It should be hidden somehow. Anyone could let me know how to make "LaTeX Formula" show up? Thanks a lot.

enter image description here

  • 2
    What have you tried already? Just googled and got many results: 1, 2? – Juancho Apr 4 '17 at 19:20
5

You need to install lots of additional software to get the LaTeX extension to show up, and to work. As far as I've been able to ascertain, it only works with old versions of Inkscape, and all the sites which show instructions seem to be old and out-dated.

Anyhoo, that's probably not what you want to hear, but there is a work around to get LaTex generated graphics into Inkscape.

Use this site: http://www.tlhiv.org/ltxpreview/ to enter your LaTeX code, and click the "popup" button, then right click the image in the popup and save the page as an SVG on your desktop. Then you can click and drag it into an Inkscape document. Less than ideal I suppose, but it works.

3

A bunch of sotware must be found on your computer. In addition some environment variables must be set manually to make the software working together.

Inkscape needs textext extension. Textext is useless if it can't find the following installed before to your computer:

  • Ghostscript (=postscript language clone)
  • GsViewer (= graphical user interface for Ghostscript)
  • Image Magic
  • pstoedit (=vector drawing format converter)
  • LaTeX distribution package, for example MikTex

There's old documents on how to get TeXtext inserted to Inkscape in Win7 machine. This info is copied from https://people.orie.cornell.edu/jmd388/design/guides/textext.pdf

Unfortunately I have no documents of succesful installations for Inkscape 0.92 in recent Windows. This has actually zeroed my possiblities to prepare full scientific presentations in Inkscape. Fortunately the need is only occasional.

For occasional needs of formulas I have 2 workarounds. They are based on Microsoft stuff that are far from the available control in TeX. From recent Word the formulas are exportable as bitmaps.I have taken high zoom screen captures. From very old Word one can easily extract separately runnable EQNEDIT.EXE. From it the formula is copyable to the clipboard as EMF, which is a vector format. No use to try to run EQNEDIT in 64 bit Windows. It doesn't start with any compatibility settings.

EQNEDIT uses font MTExtra.ttf as the formula building blocks. That font must be available where the enhaced metafile is used. In 64 bit Windows MTExtra is not noticed by Inkscape. Adobe Illustrator can use it.

To use old working systems easily I have kept alive a separate WinXP machine. It has no internet.

  • I had some trouble with pstoedit (If I understand correctly the svg plugin costs extra now), however textext latest beta supports pdf2svg another program to install, but £40 seemed steep and I could not test the plugin as my linux distro is not directly supported by the pstoedit plugin. – ted Jun 10 '18 at 14:36
1

The Inkscape wiki describes how to do this here (link). Only three programs are required to get this working (latex, dvips, pstoedit) and you most likely have at least one or two already installed. The dependencies for pstdoedit are rather substantial though. If you are using Linux or MacOS, these are simple to install. For example with Ubuntu:

sudo apt-get install texlive pstoedit

Now, the menu item displays when you load Inkscape.

  • This worked for me! – zkytony Mar 14 at 10:46
1

Indeed, it seems this option has vanished in the new Inkscape distributions. I have been able to successfully use the new textext plugin from https://textext.github.io/textext/index.html on windows 10. Installation instructions are well-documented. This plugin allows latex formulas to be inserted into Inkscape documents via the Inkscape tab “extensions -> textext”, also for Inkscape 0.92.

0

Here's the texext version from 2018-01-17 with installation instructions:

protected by DᴀʀᴛʜVᴀᴅᴇʀ Mar 4 at 12:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.