1

There's this thin orange-ish outline around the text. I am talking about the ultra thin color around my text, you can clearly see it on the @ character, there's a "stroke" around it, though I'm 100% certain it is not a stroke.

I'm guessing it is Illustrator's way of telling me that text color should not go with that background color, because it seems to go away when I switch to certain background colors. But I don't like to be told what to do.. :|

Screenshot

So how do I get rid of this regardless of what background color I choose?

  • I know this is an old post, but to me it looks like it is because the text is selected and has an orange selection indicator around every shape, not just the box rectangle. – Rick Henderson Oct 15 '17 at 2:06
6

This has more to do with how Illustrator handles the font's antialiasing/hinting than anything else. There is some transparency on these fonts that may not resolve well on certain colors. Sometimes Illustrator just doesn't handle pixel-related things that well.

Photoshop handles pixel-based images better, so if you try this text on that background color in PS, you'll find that you don't get that slight border. If the intent of this document is to print, though, you'll probably find that printing from Illustrator will yield text without the border. Illustrator/vector art does better on printers.

Hope this helps!

  • Hmm, so there's no fix to this? Well thanks for clearing it out for me anyway :) – Sion Aug 9 '12 at 17:58
  • Well, I hate to say that there's NO fix...I know these programs pretty well but I'm always learning too. But I don't think there is. The good news though is that if you take that image and do Save for Web, it seems to disappear. And like I said, it should go away when you print, and I bet it will if you export to PDF. So you might only have to put up with it in Illustrator itself :) – Brendan Aug 9 '12 at 18:03
  • Yea, I guess I'll have to live with that. Thanks :) – Sion Aug 9 '12 at 18:05
  • There is a fix.. see my answer :) – Scott Aug 9 '12 at 21:15
6

As Brenden points out, it is due to anti-aliasing in Illustrator.

It won't effect output.

However, if it really bothers you there is a workaround.

Set the text blend mode to "Multiply" in the Transparency or Appearance Panel.

Here's the difference:

multiply

Overprint will have the same effect. If you set the text to Overprint Fill in the Attributes Panel then turn on View > Overprint Preview you'll also eliminate the anti-alias "glow" which can appear.

overprint

Overprint Preview may have some undesired effects when using Save For Web however. So it's best to use Multiply if the project is destined for screen reproduction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.