0

I apologize in advance for failing to ask my question articulately. I'm pretty new to illustrator and following a tutorial where he/she at one point changes the colors of the outline of the mug seen here -->

tutorial pic

For me, I have all these anchor points and guidelines and however I try to change the color of just the path, I either end up changing nothing or filling my objects. Is this because I expanded my ellipses?

Here's what my line looks --> my mess of a facsimile

Hopefully one of you can translate what I just said into something meaningful.

1

The problem here is pretty obvious. Some of those paths have white fills. When you expanded those, they were put in a group containing the fill and the stroke as separate paths. So when you select that object that looks like an expanded stroke on a white background, you are actually selecting a group that contains the fill as well.

A simple solution, if you don't want to change anything, would be to use Edit > Edit Colors > Recolor Artwork.... In there you can change the colors of your selection pretty easily.

The proper solution might be to make sure that you get rid of that white fill if you don't need it... or separate it from the stroke by ungrouping it, if you think that would make your life easier. Often times people use the Recolor Artwork until the design is finished and then finalize things by expanding and cleaning up things.

0

It might have been better if you had shared the .ai file at a file sharing site such as filedropper(dot)com so we could take a look. It's quite difficult to tell exactly what's going on from your screen shots.

However, I'll take a guess. It seems like when you expanded the strokes, the shapes already had a white fill attribute. Now they have been expanded, you should still be able to select the white fill with the Direct Selection tool (A) and simply delete it.

0

Looks like your shapes had a white fill when you expanded/outlined your stroke so you now have the stroke and fill both as individual filled shapes (and when you're setting your fill color you're setting it on everything). All you really need to do is delete the fills... If you do that you'll see that horizontal crossbar from where the two semi-ellipses meet though (like this).

The easiest solution is to use Pathfinder...

Take this similarly constructed shape:

enter image description here

Select it all and hit "Merge" from the Pathfinder panel:

enter image description here

Use the Direct Selection Tool to select only the white areas and hit delete:

enter image description here

...another option is to use a transparency knockout group.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.