0

I've recently noticed a problem when using the export to SVG feature of Adobe Illustrator. (CC 2015.3)

I import into my document some stuff (For example from a PDF), but when I export them into SVG and reopen it, the outlines look like they've been "drafted"...

Here you have an example:

These are the original SVG shapes when I'm editing them:

This is the output upon exporting it to a SVG file...

What could be the problem?

4
  • 2
    to be honest both images look very much the same except for that little blue extra object on the second one... Are you sure there are no stray anchors or open objects? Have you checked the outline view before exporting?
    – Luciano
    Commented May 9, 2017 at 14:45
  • @Luciano Differences might be more visible with a little more of zoom. Take a look now. Original --- SVG Export
    – JotaEle
    Commented May 9, 2017 at 14:53
  • Thats IS strange. Have you expanded everything and have you made sure that the paths are closed?
    – Wolff
    Commented May 9, 2017 at 15:02
  • @MadsWolff It happens all the time... Some errors aren't quite noticeable if not zoomed, so I was terrified when I knew I've been producing low quality graphics. I think it can't be a problem of open paths.. Here you have another test. I've converted to outlines an Helvetica's "a" and exported it to SVG... Look at the comparison -- and paths
    – JotaEle
    Commented May 9, 2017 at 15:17

1 Answer 1

1

I think I have the answer:

When saving the SVG you can click a button called "More options".

Now you have the possibility to change the number of "Decimal Places".

If the number is too low the positions of the points will be rounded.

The smaller the document size, the more visible the problem gets.

Try choosing a bigger number or scale your document up.

2
  • Yeah, that's the correct answer. The number of decimals was set to "1". I wonder if I changed it by mistake or if this is the default value of Illustrator. Thanks a million! :)
    – JotaEle
    Commented May 9, 2017 at 19:02
  • No prob. In my Illustrator it was set to 3.
    – Wolff
    Commented May 9, 2017 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.