0

How do i find and change space + questionmark in GREP mode in InDesign. It seems the intuitive way by just typing in those two characters in the Search-bar (Ctrl+f) doesn't seem to work. Also the spaces special character doesn't work for me. Any hints on how to do it properly?

5
  • What "Search-bar?" A web browser search bar? Your File Manager search bar? This forum's Search Q&A bar at the top right corner of the screen? A mobile app search bar? The answer you seek may depend on the environment you are experiencing trouble in.
    – jhurley
    Commented May 11, 2017 at 13:27
  • "The Title is rather selfexplanatory." I'm afraid it is not to me. Please edit your question and try to explain what you tried, why it did not do what you expected and what it was you expected. Do not expect from us to try and replicate your problems, we don't have the time and, frankly, why should we be bothered if you can't?
    – PieBie
    Commented May 11, 2017 at 13:40
  • 1
    err... find and replace (ctrl+f)? Maybe its not a space at all.. Then use grep "\s[?]"
    – joojaa
    Commented May 11, 2017 at 13:41
  • Yes Ctrl+F "Suchen und ersetzen" in german... Sorry for the bad translation. I have tried Grep and Text Options and both to no avail. Commented May 11, 2017 at 13:47
  • Thank you for the edits, the question is already clearer. I withdrew my -1.
    – PieBie
    Commented May 12, 2017 at 7:08

3 Answers 3

7

Use GREP search query.
Search for \s\?
Replace by ?
Check the target of your query (document, story or selection). This is probably why you couldn't make it work properly.
See example below of a couple of different kinds of spaces that would be affected:

enter image description here

5
  • This did it... for some strange reason did Indesign write "\s" instead of "\s\" if space is chosen through the menu. Typing it in by hand works fine. Thank you ! Commented May 11, 2017 at 13:52
  • 1
    \s stands for "any space" while \? stands for "question mark". ? character has a special meaning in Grep query, so you either need to "escape" it using backslash (like I did) or put it in a class like this: [?], just like Jooja suggested.
    – Vinny
    Commented May 11, 2017 at 13:58
  • thanks i haven had too much experience with that before, so i learned something new today :) Commented May 11, 2017 at 14:09
  • have a look at ericagamet.com/wp-content/uploads/2016/04/…
    – Lucian
    Commented May 11, 2017 at 14:11
  • 1
    @Lucian naah never leave home without Regular Expression Pocket Reference
    – joojaa
    Commented May 11, 2017 at 14:54
0

The standard search box (top right) does indeed seem to have some kind of issue with locating [SPACE]? but if you use the standard Find/Change dialogue Control+f it works fine. Just make sure to select "Forward", or "Backward" depending on your cursor location in the document.

In fact I've never even noticed that search box before, and can't confirm what it does!

1
  • ..a special thanks for leaving the word GREP out of your self explanatory title until edit :) Commented May 11, 2017 at 14:19
0

You can use a script called "Use my Typo" that let you put/delete space after/before any character and many others (like delete multiple spaces)

also in the search/replace window if you put space using the space button it don't work. You need to use symbol for space, like "^m"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.