1

Is it possible to export PowerPoint to PDF with vector graphics preserved? Any method I try seems to rasterize all images, even though most, if not all, are .SVG placed in the PPTx presentation.

UPDATE

Solved---somewhat.

Sorry about the delay here. I am not exactly certain HOW it was solved (I suspect an update to Acrobat or PowerPoint or both) but nevertheless it more or less works now 🙂

With an Office 365 Subscription and the latest versions of PPT and Acrobat, and the "High Quality Print" setting checked on the Acrobat Add-in Preferences (accessible within PowerPoint) you too can Create a PDF and preserve the SVG graphics you have placed in your PowerPoint deck. The same works with Microsoft Word and Excel.

HOWEVER --- you need to ensure that your SVG does not use any gradients at all or the image will rasterize on export. Furthermore, your SVG absolutely CANNOT have any Clipping Masks within or it will rasterize on export to PDF. I really TRULY wish neither of these limitations still existed but as of 12/15/2017, they unfortunately do. Hint and wink to any Adobe or Microsoft development team members who may come across this post ;-)

  • 1
    PDF is not a vector-based format, so I am guessing that you mean that the quality of your images in the final PDF has degraded so that they are pixilated. Even if that assumption is correct, you haven't given us much information to go on here. How are you converting it? Using the print to PDF option, using an Acrobat add-on, etc.? My immediate instinct is that your PDF conversion settings need to be tweaked, but without knowing how you are creating the PDF, there is no real way to know. – magerber May 16 '17 at 22:34
  • 1
    Before anyone jumps in to correct me...let me rephrase--PDF is not inherently a vector format, but it can support vector images. – magerber May 16 '17 at 22:36
  • I use Acrobat as an add-on to PowerPoint. I would like to create a PDF with embedded vector images. I have used the Add-on itself, print to PDF, etc. using several combinations of settings and in all cases, the images are rasterized, which I do not want in order to avoid pixelation. – Sean S. Bach May 17 '17 at 23:06
  • I'll jump... PDF is probably a vector format that can support raster and other type of content. – Rafael Dec 15 '17 at 18:47
1

I don't know if this will solve your problem or not, but I think the issue you may be facing has to do with the settings when you are creating the PDF. Unfortunately, each version of Powerpoint and Acrobat interact a little differently, so the steps I offer here may not work the same way for you. But, just in case, here is how I change the settings in my version of Powerpoint.

Click on the Acrobat option in the ribbon, and choose Preferences: enter image description here

As you can see, the default setting is "Standard."
enter image description here

Choose "Advanced Settings", and then click on the "Images" icon at the left. enter image description here

Set the Image Quality for both Color Images and Grayscale Images to Maximum. This should solve the problem for you. If it doesn't, experiment with raising the pixels per inch amount from 150 to 200, and see if that makes the difference.

If you don't have an Acrobat tab on the ribbon, check and see if there are "Export Options" offered on the tab where it allows you to name and save your new PDF. I can't show an example of this because it is no longer enabled on my computer, but previously that is where I was able to find and edit settings for creating PDFs. Basically, you want to make sure that any downsampling of images is done at the highest quality possible.

Earlier versions of Powerpoint did not allow you to modify your PDF output options in as much detail as this version does, but they have always provided an option to select a higher quality PDF than is created via their default settings. The challenge is trying to find the location to access those settings.

Hope this helps.

  • Thanks for your reply. Unfortunately, I have tried several settings but none, including removing all downsampling and compression, preserves the vector images within. – Sean S. Bach May 18 '17 at 14:31
  • Sorry about that then. My gut instinct says it is related to trying to use vector images with a Microsoft product--Microsoft builds in a lot of under the hood programming to "make things easier" for its users, but that generally just keeps me from being able to accomplish what I want to accomplish. But there may be other users here who have other ideas about what might help you. – magerber May 18 '17 at 21:07
  • My sad experience is that any effect applied to a perfectly correct vector illustration makes PowerPoint revert to flattened low-resolution bitmaps. No amount of tinkering with settings help at that point; you have to physically remove PowerPoint – oops – I mean the effect. – usr2564301 Dec 15 '17 at 15:08
1

I had this problem when I inserted SVG graphics in Powerpoint. However, when I inserted EMF graphics to my Powerpoint and saved to pdf, it correctly maintained them as vector graphics. I converted my SVG graphics to EMF using Inkscape, which is free.

1

Solved---somewhat.

Sorry about the delay here. I am not exactly certain HOW it was solved (I suspect an update to Acrobat or PowerPoint or both) but nevertheless it more or less works now 🙂

With an Office 365 Subscription and the latest versions of PPT and Acrobat, and the "High Quality Print" setting checked on the Acrobat Add-in Preferences (accessible within PowerPoint) you too can Create a PDF and preserve the SVG graphics you have placed in your PowerPoint deck. The same works with Microsoft Word and Excel.

HOWEVER --- you need to ensure that your SVG does not use any gradients at all or the image will rasterize on export. Furthermore, your SVG absolutely CANNOT have any Clipping Masks within or it will rasterize on export to PDF. I really TRULY wish neither of these limitations still existed but as of 12/15/2017, they unfortunately do. Hint and wink to any Adobe or Microsoft development team members who may come across this post ;-)

  • Please update your question, you do not need to answer your own question to post an update. – Ovaryraptor Dec 15 '17 at 22:42
  • 2
    @Ovaryraptor: wrong. "Updating the question" with what? The answer? Then it's no longer a "question"! Self-answering has always been specifically allowed. (Although more details would be helpful for others with the same question.) – usr2564301 Dec 16 '17 at 0:10
  • I did both. Hopefully that appeases everyone :-) – Sean S. Bach Dec 16 '17 at 2:13
  • It is perfectly valid to answer your own question. Even it is valid to mark it as the "accepted answer" if it is the case. – Rafael May 2 '18 at 16:23
0

I managed to do this via the simple 'save as' function. Select PDF from the drop down, then hit more options, tools, compress pictures, and choose keep originals. Worked for me, with only one odd effect on an SVG (though they were mostly line-drawings so YMMV).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.