I'm trying to install this plugin on GIMP 2.8 on Windows 10. I've followed the instructions and copied the scripts on my plugins folder but I can't find the plugins or the Sprite Sheet menu.

I've tried to find it on the Plug-in browser, without success.

Is there any compatibility issues? What did I do wrong?

EDIT: I've reinstalled GIMP and now works properly and, finally, I can find my plugin. I have no idea what caused this problem.


Missing plugin:

  • Navigate to your Gimp profile directory
  • open the pluginrc file with a text editor editor.
  • search for the plugin file in a line that starts with (plug-in-def
  • If the file is listed, then your plugin is installed, but you could be looking for it at the wrong place.
  • The following lines list the functions in the plugin file, together with their menu entries.

If you didn't find the plugin listed there, it didn't register correctly:

  • because it was not where Gimp looks for plugins:
    • Go to Edit>Preferences>Folder>Plug-ins to see where Gimp looks for plug-ins
    • check that you put the plugin in a directory listed there.
  • because there was some error when registering the plugin
    • start Gimp in verbose mode (add a --verbose parameter in the shortcut)
    • gimp will run with an additional console window
    • check for errors in that window

A frequent problem with Python plugins is people who edit them by mistake and alter the code indentation (which is significant in Python). This make Python report a syntax error during the registration and the registration fails. Trying with a freshly re-downloaded and unaltered copy of the plugin may fix the problem.

  • Thanks for your answer. I'm accepting this answer as it's the most complete and it helped me to find a solution. – forameuss May 29 '17 at 9:39
  • @forameuss what was the problem? – xenoid May 29 '17 at 9:48
  • I followed all your steps, but the scripts didn't install for no reason. I even started Gimp in verbose mode and the only thing that appeared was a generic error. So I reinstalled GIMP and the scripts, and now it works!. I have no idea why this is so. – forameuss May 29 '17 at 9:59
  • I had this same issue, I opened GIMP in Verbose mode and found that I was getting the error "Removing duplicate PDB procedure" when it tried to load the missing plugin. I realised that I had copied the code from another plugin to use as a template, and had failed to change the name in the Register section (i.e. the first property: register( "plugin_name") - as soon as I changed that to something unique, it showed up in the menu, right where it was supposed to be. – LoquaciousDandy Aug 1 '18 at 13:19
  • @LoquaciousDandy Glad it worked, but it is even more useful to others to upvote the answer than to post a comment (hint, hint...) – xenoid Aug 1 '18 at 16:33

You need to put the .py files in your GIMP Plug-ins folder.

  1. To find your plug-ins folder, click Edit > Preferences > Folders > Plug-ins

  2. This should display the paths for your plugins folder. Quite often there is more than one location, all locations listed should work. Take a note of the location - or just copy the path.

Note: in Windows, the usual Plug-in path is at C:\Users\YourUserName\.gimp-2.8\plug-ins - but it's often best to check as shown in steps 1 and 2 above. It could potentially be different on your computer.

  1. Navigate to that folder on your computer using Windows Explorer. If you previously copied the path, you can paste the location into the address bar along the top, then copy and paste the two .py files into that folder.

  2. Quit and restart GIMP

  3. You will be able to invoke the plug-ins by clicking Filters > Sprite Sheet

Here's a screenshot showing the location in the Filters menu. Screenshot of GIMP Filters menu

Not the answer you're looking for? Browse other questions tagged or ask your own question.