3

I don't have a good way to explain this just using words, so here's a partial screenshot:

Weird selection result


Even when I set the threshold to 0, Fuzzy Select is grabbing a disproportionately large portion of an image. In the screenshot, I'm trying to only grab the darkest color. It's almost like there's an after-image stuck in the tool's settings. There's only one layer (with no layer mask) in the xcf, so it's not an issue of having the wrong layer selected.

Am I just flat-out doing something wrong? I tried messing with all of the other tool options, but haven't had luck.

2

Because it selects by color, and the difference between the black area and the near-black area is not color but opacity (you can use the Pointer dialog to check this). To achieve what you want:

  • Layer>Transparency>Alpha to selection to generate a selection based on transparency
  • Select>Selection editor to open the selection editor. You will get a "negative" of your image (white is what is fully selected, and the "Alpha to selection" selects pixels according to their opacity).
  • Click on the white part (this acts as a "Select by color" on the selection values) and this should restrict your selection to the fully opaque bits.

Alternative method:

  • Layer>Transparency>Alpha to selection to generate a selection base don transparency
  • Select>Save to channel to save the selection. At that point the saved channel is the "active drawable" and so the Paint tools will act on it.
  • Use the Threshold tool to remove the gray band.
  • In the Channels list, right click and Channel to selection to make a selection from the result.
1

I think the problem is because you have different areas of transparency - but the Fuzzy select tool works by comparing differences in colour.

Here's a workaround that might solve it for you.

  1. Create a white background layer below the image layer/s, and enable its visibility.
  2. Set the fuzzy select tool options to Select by: Composite and Sample Merged
  3. Try to make your selection again.
  4. When you have finished, you can hide the background layer visibility, or just delete it.
  • 1
    Select by Composite just selects using RGB. Your solution works if you use "Sample merged". – xenoid Jun 8 '17 at 12:25
  • @xenoid You are absolutely correct, I missed that out!!. Edited my answer. Thanks for that. – Billy Kerr Jun 8 '17 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.