Older versions of Photoshop had ImageReady that allowed you to import GIFs and load each frame as a layer. Apparently that doesn't exist anymore and I really need it. I'm using CS4.

I have tried loading it into GIMP and saving as a PSD, but that resulted in the layers being flattened. I tried many image converters, but they either only converted the first frame, or created a separate PSD for each frame...



1 Answer 1


Adobe really hosed CS3 and CS4 where this is concerned.

To open an animated gif with Photoshop CS3 or CS4 choose File > Import > Video Frames to Layers. This will open the animation but in my experience you lose all transparency for the frames. So you have to reconstruct the transparency if it exists. There is simply no way to open a transparent animated gif and retain both frames and transparency with Photoshop CS# or CS4.

It may be worth your while to go find some freeware which will open the gif and save it as a PSD. If I remember correctly, at the time, I found a $5 app that did just that and solved the issue. I can't recall the app name now though. I simply found it by searching for "edit Animated Gif" on download sites.

This issue was fixed in Photoshop CS5. Photoshop CS5+ will open transparent animated gifs without issue.

  • To add to your answer, Scott, you won't be able to see the .GIF file until you put the * character into the file name field and pressing enter.
    – Hanna
    Sep 7, 2012 at 21:29
  • I don't appear to have that option... Sep 7, 2012 at 21:31
  • It's been a while. It may only work with CS4 Extended. If you post the animation you need to open somewhere, I'd be happy to open it and resave it as a .psd for you. @Johannes not on the Mac :) Actually I can't test much here. CS4 runs a bit less-than-ideal on Mac OS 10.7.
    – Scott
    Sep 7, 2012 at 21:42
  • Make sure you're sunning the 32-bit version of photoshop, Kolink, it does not appear to appear in the 64-bit version.
    – Hanna
    Sep 7, 2012 at 21:45
  • Good catch :) I wouldn't have thought of that.
    – Scott
    Sep 7, 2012 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.