1

I have a o that I traced. I removed the white background by selecting expand and clearing it. however, the white background is still in the test part of the logo. thanks for any help you can give me.

1
  • Could you maybe post a screenshot including your layer panel? I'm kinda confused - if you drew a logo in illustrator just delete the rest of the layers/objects – Ryan Jun 29 '17 at 16:16
1

Metis' method (ticking 'Ignore White') works perfectly in this case (when the background color is white)...

But if the background isn't white (and you want to keep your colors) how to proceed?

Assuming a two color trace – this method will work no matter what the background color might be.

When you do your trace, open the Image Trace Panel (Window > Image Trace) set it up beforehand as 2 color:

Two color trace

Then hit the 'Trace' button followed by the 'Expand' button.

Now press the A key, and click on your background. Then go to Select > Same > Fill Color:

Select menu

And lastly, just press the Del key.

Done like dinner. Before and after:

The Trumpster

4
  • Thank you for sharing this method. I am new in illustrator and so far have my experience has been with white backgrounds. I am sure I might work with images that have different backgrounds and I will definitely revert to the above method. Thank you once again – Maha Jul 2 '17 at 0:52
  • @Maha Hey, no problem... Glad I could help. If you found this answer useful please vote it up so I can get rid of the 666 already Lord have mercy – BANG Jul 2 '17 at 4:00
  • excuse my ignorance, but how do I vote it up? – Maha Jul 2 '17 at 13:00
  • To the left of the top of the answer: up and down arrows (to vote up/down) and a check in a diamond to accept an answer. – BANG Jul 2 '17 at 13:11
3

One of the easiest ways to handle this is to plan ahead.

On the Image Trace Panel, expand the Advanced options area...

Then tick Ignore White.

enter image description here

This will eliminate the tracing creating white objects, but it will still create counters or "holes" in other objects.

Without this option ticked, what happens is the trace creates an object, traces the counter/hole for the object, then creates the counter and a white shape above the counter. So you end up with the object plus white shapes where there are counters/holes. By ticking Ignore White none of those white shapes are created.

Then you can proceed to Expand and refine the elements after tracing.

1
  • oooh they're trying to auto-trace – Ryan Jun 29 '17 at 16:37
0

After expanding the white background might still be attached in pieces. Sometimes after tracing a circular object I have to delete 4 corners of white background.

Expand > Ungroup > Delete everything you don't want > Regroup what's left

3
  • I have tried ungrouping and deleting the fill in the text, but it becomes one solid car like the O for instance – Maha Jun 29 '17 at 16:14
  • Oh, so you have a situation with an "O" where the middle part that is supposed to be cut out is actually a white shape? You need to clip the middle shape out of the O. Select both the middle shape and the O and go into the Pathfinder window and use Minus Front. – Webster Jun 29 '17 at 16:16
  • 1
    Wow, it worked!!! I can't thank you enough! Thank you so much cause it drove me crazy the past 2 days reading everything about clipping the white background out and nothing worked in the text part! now I can proudly us my logo:) – Maha Jun 29 '17 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.