5

When I generate a PDF from a Drawing using Inkscape 0.92.1 on Ubuntu, it creates a multiple page document which is barely not displayed then in a LaTeX document.

How could I prevent Inkscape to make multiple pages PDF?

Here's the pages layout on the PDF document viewer on Ubuntu (Evince) just to clearly see the problem:

PDF multiple pages output in Evince on Ubuntu

  • Did you forget to post an example image? or example of the PDF? – Billy Kerr Jul 7 '17 at 7:12
  • I had error yesterday with image upload. It's beeing fixed now. – s.k Jul 7 '17 at 10:24
  • I can't replicate the problem. When I export a PDF from Inkscape, I get a single page document. – Billy Kerr Jul 7 '17 at 11:27
  • What are your page settings for the document? Does your drawing fit on one page in Inkscape? – user unknown Jul 11 '17 at 13:19
  • Maybe you should add the key element to this question: you export to pdf while selecting omit text in PDF and create LaTeX file. And to prevent layers, move all text to the foreground prior exporting, see tex.stackexchange.com/a/350175/36296 – user61223 Jul 11 '17 at 18:32
1

The problem with the additional page has been fixed, see https://bugs.launchpad.net/inkscape/+bug/1417470/comments/45

This will still create multiple layers, which is intended behaviour. If you don't like it, a workaround is to move all text to the top layer, see https://tex.stackexchange.com/a/350175/36296

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.