0

In InDesign, I have made sure that URLS in my citations are not hyperlinked. However, when I export the file and open the PDF, I can click on the URLS and access the linked websites. How can I prevent this from happening?

  • 1
    Are you saving as (Print) or (Interactive). How are the websites written, are you adding "http://" in front of the URL's? If exporting as print pdf, do you have bookmarks checked under the include section in the export window? It also may be something that you can't stop because this is a setting from Adobe Reader that will automatically read URLs and make them clickable. – AndrewH Jul 28 '17 at 19:30
  • I am saving the PDF as interactive. Some links in the file need to be hyperlinked, while others do not. Yes, the URLs start with "http://". If I don't include that, would they not be hyperlinked by Adobe Reader? Thanks! – Katy Kauffman Jul 28 '17 at 19:37
1

This is a preference in Adobe Reader that makes URLs that start with "http://" or "www..." clickable. This happens even if you do not make them hyperlinks in InDesign.

You can find this under Preferences -> General. Under Basic Tools uncheck "Create links from URLs". This will only affect your computer.

The only way I know to prevent this without needing to uncheck the preference is to write your URLs as "yourdomainname.com", so not adding www or http:// to the front.

  • Can I turn off this feature on my end? I found that someone receiving the file can block all URLs. – Katy Kauffman Jul 28 '17 at 19:40
  • @KatyKauffman Yes, in Acrobat or Reader in Preferences -> General. Under Basic Tools uncheck "Create links from URLs". Now only text that was created in InDesign as hyperlinks will be links. – AndrewH Jul 28 '17 at 19:43
  • Thank you. I unchecked "Create Links from URLs." Can I save my file this way and send it to my readers? I don't see a save button in Adobe Reader. I have the free version. – Katy Kauffman Jul 28 '17 at 19:46
  • @KatyKauffman This preference will only be done on your computer. You cannot save the PDF and have the preference be the same on another computer. The users that open this file on their computer will also have to make sure they uncheck that option. – AndrewH Jul 28 '17 at 19:48
  • You've been a great help, especially answering so quickly. Thank you. – Katy Kauffman Jul 28 '17 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.