1

I am creating a vectorized version of my school's logo because we currently only have a low-res bitmap version. The logo includes text on a circular path, so I used the Text on Path feature in Sketch to achieve the effect.

The trouble is that when I export it to SVG (my desired format), the Text on Path does not export properly, and the text appears to be just normal lines of text. How can I fix this issue?

This is a screenshot of how the text appears in the Sketch app

This is how the text appears when exported to SVG (the text is highlighted for visibility)

Thanks!

1
  • Have you tried converting the text to outlines? How to here
    – Billy Kerr
    Jul 30 '17 at 9:52
2

Sadly, not every SVG renderer supports text on paths, even though they are part of the SVG spec.

So I would recommend creating two files: one "original" file with the text on the path, and another with the text converted to a path or outline or whatever. Then export the second one to whatever other formats you need, like JPEG or PNG.

2
  • When I do this, it shifts the text from an outside curve to an inside, and moves it; it doesn't just convert it to outlines and leave it alone. Oct 18 '18 at 13:08
  • 1
    Try using a different software to do the conversion, such as InkScape.
    – posfan12
    Oct 20 '18 at 5:52
3

You need to select the text, and click "Layer->Convert to Outlines" and then the text gets to be part of the image

1
  • this should be the accepted answer Jan 20 '21 at 23:27
1

I haven't used Sketch, but it may just be that your logo and/or text needs to be converted from an object to a path, as is the case because png formats for example can't handle unless you do a conversion to a path first.

3
  • 1
    Menu option Layer->Convert To Outlines should do it.
    – Gus Shortz
    Aug 5 '17 at 4:53
  • PNG format has nothing to do with it.
    – posfan12
    Sep 28 '17 at 7:35
  • Convert to outlines results in the same problem, the text is removed from the path before converting it to outlines.
    – Nilloc
    Jun 13 '19 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.