I'm having a bit of an annoying issue. at my work I often have to edit files where I don't have the font on my computer and that's fine, I usually find the font, install it, and it's fine. However, there are some fonts that, even after I change them, the "missing font" with the diamond next to the name remains in my list of fonts, so even if I open up a new file, those fonts are listed with the diamond next to them, and appear as the pink highlighted text. Is there a way to remove those fonts from the dropdown list of fonts? it's really annoying when I'm going through them and I have a bunch that are not useable. I've attached a screenshot of what I mean with red lines next to the fonts in question. In the file in the screenshot, it's a new file I'm working on where I'm NOT using any of those fonts, so why are they listed? It's so annoying and I just want them to be removed. I understand showing them when I have a file open that contains missing fonts, but not when I'm working on a file that doesn't contain them.

Edit: I'm on a mac, should have mentioned that to start, sorry!

whyyyyy

  • I believe the contents of C:WINDOWS/FONTS is what determines the list that shows up in your program. Edit the files in the FONTS folder, restart your system and see if it solved it. – Webster Jul 31 '17 at 15:41
  • Sorry I should have said that I'm using Mac. Never posted here so sorry I should have included that. :( However I did go look at my font book at my list of installed fonts, and the ones shown in the screenshot aren't even installed, so I have no idea why they are showing up. – Rinzler Jul 31 '17 at 15:44
  • I believe the same method applies on Mac. Remove the fonts from the font folders and they should not show up in your program, after restart. It sounds like there are 4 font folders on a mac, with different permissions: support.apple.com/en-us/HT201722 – Webster Jul 31 '17 at 15:47
  • I believe those are just the fonts used in your AI that aren't on your computer... are they still there if you close all documents and restart Illustrator? – Cai Jul 31 '17 at 16:14
  • Cai - No they are not being used in any of the files I have open. Like I said this screenshot was taken from a new project I had open in Illustrator that I barely had any objects in. No other files were open in my illustrator and they have been in my font list for weeks now, after multiple times closing the program and restarting the computer. I also checked several font folders on my mac and I can't seem to find any of the files listed, so I'm still very confused about why they're showing up haha. – Rinzler Jul 31 '17 at 16:16

This may be worth a try: Open the offending document and Go to the Menubar > Type > Find Font. Then click the missing font and choose a font from your System that you know that you have. Select Change All, until you no longer have any missing fonts in the document. Hopefully it will clear whatever cache that is causing it to show on the font list.

Find Font dialog box

Have you tried resetting the application's preferences? Just hold Option+Command+Shift as you start Illustrator.

Also, trying something like: Font Cache Cleaner or FontNuke might help. It cleans up any corrupted fonts from your computer's different caches.

  • I tried holding Option+Command+Shift during illustrator startup and they are still there. I tried downloading FontNuke but unfortunately my computer's security preferences are not letting me actually use it. Can't seem to find Font Cache Cleaner anywhere online. Blah. – Rinzler Jul 31 '17 at 18:00
  • If you go to System Preferences -> Security & Privacy -> Allow Apps Downloaded From just after you open Font Nuke, you'll see the option to "Open Anyway" and will be able to use the program. – AdrieGonzalez Jul 31 '17 at 19:38

The issue comes from opening up a file(s) that are missing fonts according to your system.

I get this most often when I have say Helvetica Neue Roman being called out when I have Helvetica Neue Roman 55 on my system. Fonts are finicky like that where they need the EXACT naming convention to successfully link.

This is avoided by correctly replacing all fonts on opening the document. You have these "artifacts" because at some point you opened a document and didn't correctly relink all missing fonts to a replacement.

Solutions

  1. Always link all fonts when opening a document
  2. Use Font Nuke to try and remedy the errors (NOTE: the program can be quite aggressive so use caution before messing with all your fonts and save a back-up!)
  3. Try resetting your fonts to the default Adobe fonts and then reinstall all of your fonts. (NOTE: Again back-up all of your fonts prior to resetting.)
  • Thanks. Unfortunately deleting all of my fonts and reinstalling them would be way more of a pain than just having these floating around, considering I have hundreds of fonts, literally. I tried downloading fontnuke but my computer's security settings won't let me use it. It looks like I'm going to be stuck with them for now! Thanks for your answer, I'm sure those things would work great if I had different circumstances haha. – Rinzler Jul 31 '17 at 18:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.