1

When placing an ICML file into InDesign, it gives me a text frame which is right-aligned. The content is in English and I can't change the alignment of the frame unless I “Check out.” I would like to change the alignment of this frame without “Checking out.”

I have tried changing the Story direction, changing the language from the Character panel, and resetting the Basic Text Frame object style to default.

I have the ME edition of InDesign so I also tried creating a regular text frame and then importing the file into it, but alas, it is still right aligned.

I've read the following without finding a solution:

  1. How to change default text settings in Adobe InDesign?

  2. Adobe Indesign frame converted to text frame right aligns

Here's a screenshot:

Screenshot of right-aligned frame

0

This might be related to differing styles definitions in your version of InDesign/InCopy and that of the designer who created the original InDesign file.

If you have changed your default paragraph style to be right-justified (you mention that you have the ME version of InDesign, and I know that at least Hebrew is read from right to left-there may be other Middle Eastern languages that also are read in that direction), then InDesign will have automatically made that change to the [Basic Character] style for your documents.

If the original designer created paragraph styles that were based on the [Basic Paragraph] style definition, then when you import the document into your copy of InDesign/InCopy, it will bring in those paragraph styles, but will base them on your [Basic Paragraph] definition.

I have just started experimenting with InCopy, so I don't know whether you can make a change to the style definitions without checking in the icml document, but I would definitely start trying to solve your problem by troubleshooting the styles and default text characteristics.

enter image description here

  • There is no designer. I'm placing this into a brand new document. Does this help? – Khalid Hussain Aug 3 '17 at 23:13
  • Sorry...I don't really know enough about using InCopy to respond to the checking in/checking out portion of your question. But, in terms of the right justified text, I still think it may be related to the default paragraph formatting in InDesign. Did you follow the instructions for resetting your default language and paragraph styling mentioned in the linked questions? Have you tried resetting your preferences? – magerber Aug 4 '17 at 0:52
  • Might this be that the paragraph setting form justification is set to "align to spline" or "opposed to spline", So your snippet may appear right aligned on the genuine document but will be left aligned if you place the snippet onto a different page. – Loic Sep 4 '17 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.