1

Inkscape v0.92

When I zoom I would like to see the individual pixels instead of the zoom anti-aliasing. This occurs not only for paths but also for bitmaps.

I realize there is now a 'Display: Use antialiasing' option in Document Properties but this does not facilitate my request.

  • At least for paths, that’s a feature, not a bug. – Wrzlprmft Aug 15 '17 at 19:43
  • Inkscape has no pixels! It's a vector image editor. Even if you could zoom in forever, you still wouldn't find them. – Billy Kerr Aug 15 '17 at 20:36
  • @BillyKerr It does have pixels. It keeps antialiasing as you zoom in so it appears to never pixelate. I used to use Fireworks and by default it zoomed into the pixels even on path strokes. This sounds counter-intuitive but it was helpful in certain situations. – shrimpwagon Aug 15 '17 at 20:42
  • 1
    Nah that's because you are zooming in on a raster image placed in Inkscape. It's like zooming in on a raster image on a web page or in an image viewer, it just gets blurry when you zoom in - it's not antialiasing. What you need is a raster image editor if you want to see/edit individual pixels. Inkscape/Illustrator=vector GIMP/Photoshop=raster. Essentially you are using the wrong kind of software. Fireworks was like a hybrid between raster and vector. Fireworks was nothing like Inskcape/Illustrator which are pure vector. – Billy Kerr Aug 15 '17 at 20:45
  • I think this is more what I'm looking for: krita.org/en – shrimpwagon Aug 15 '17 at 20:53
2

Sorry didn't quite understand your question, apologies for the confusion. Anyhoo, here's how to do it.

Click Edit > Preferences, and select Bitmaps and scroll down to Import

Set up as follows:

enter image description here

Now when you import a bitmap, the zoom blur rendering is switched off, so you will be able to see sharp pixel boundaries when you zoom in.raster/bitmap image

Here's a screenshot of a raster/bitmap image zoomed in with overlaid vector

enter image description here

Edit: after some chat with the OP @shrimpwagon who discovered that this fix doesn't work for images already placed in the file, it is possible to fix that by editing the XML

style: image-rendering:optimizeSpeed

Also when importing, shrimpwagon discovered that this dialog also appears if you have the "Ask about linking and scaling when importing" option checked in the import preferrences.

enter image description here

So, if you get this - choose blocky!!!

1

Inkscape is a vector illustration application. There are no "pixels" to show, as they don't exist.

Some vector illustration software, such as Illustrator (I believe) has a feature that will show you the pixel conversion in real time so you can tweak your vectors to match a particular pixel resolution output. Inkscape does not have that feature AFAIK.

  • When making web page mockups I'm using a lot rectangles on top of bitmaps. It is hard to zoom into the bitmap and line up certain things at a pixel level. Maybe I'm using the wrong software. I'm on Linux and I don't want to use Gimp. – shrimpwagon Aug 15 '17 at 20:31
  • Yea, you can't do that with Inkscape, unfortunately. You'll need to consider Adobe Illustrator. Or...you could use raster software. Not sure what alternatives there are to GIMP on Linux these days. – DA01 Aug 15 '17 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.