0

This happens occasionally and I don't know what the fix is. Illustrator cannot properly display certain SVG files that look fine in a brower and Inskscape, and validate with no errors.

For example, this file of a heraldic crown from Wikipedia Commons appears fine when I open it in Inkscape, but Illustrator goes nuts. I'm using Illustrator CC 2015 on Mac. This is how it displays in Illustrator:enter image description here

This particular file had some hidden shields outside the artboard, but I deleted them, and no change. I removed unused defs, tried saving as plain SVG, etc but still Illustrator freaks out trying to display it. I've had this happen before - sometimes the entire artboard goes gray, and while you can select elements, you can't actually see them. Copy/paste into another document brings over the same problems. Sorry if this has been I've tried searching for answers but didn't find anything. Thanks.

  • FYI the same thing happens in my AI CS6 when opening this particular file (PC/Win 7). – Lucian Aug 27 '17 at 5:49
  • Illustrator 2016 can successfully open the file on my mac – filip Aug 28 '17 at 8:27
1

OK this is not really an answer as to why Illustrator is doing it but a workaround - when I save the file as EPS from Inkscape, Illustrator opens it perfectly. This didn't work before on my earlier version of Inskcape I was working with last year. Hopefully I won't have any more problems bringing it back into SVG.

  • The SVG in your link opens fine in Illustrator CC 2017.1.0 Time to update? – Billy Kerr Aug 31 '17 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.