0

I'm attempting to create a custom font using FontForge. I'm using Illustrator to generate the paths. Unfortunately, my knowledge is with Photoshop, not Illustrator. While I've been able to create the glyphs I want in Illustrator, I'm having trouble importing them into FontForge.

Many of my glyphs are multi-part - that is, they have parts which do not connect. I suspect this is the cause of the problem. This is because while FontForge imports the glyph perfectly, it only imports one part of it, leaving all the disconnected parts behind. So for example an é would show up simply as e, because the accent mark isn't attached.

I feel like the problem is in Illustrator, not FontForge, because the objects are separate in Illustrator. I simply turned visible the parts I wanted to make the glyph, and saved the file as a new SVG file. Upon realizing this wasn't working, I tried to join the objects together, but was unable to do so. The best I can do is put them in the same group, which still doesn't solve the problem.

What do I need to do? Am I correct in assuming that the problem stems from having disconnected parts on a glyph? I've done extensive Google searches, but haven't been able to find anything.

  • Maybe a transperant line between the two objects will connect them in font forge. – Webster Aug 29 '17 at 23:52
  • Try use Ctrl 8 to make it a compound path. – LeoNas Aug 29 '17 at 23:55
1

If what you're trying to do is make glyphs with accents / diacritics, you're better off importing the components separately and then creating the combinations using anchor points. That way, for example, you can create a, e, i and ´ and generate á é í without importing the accent more than once.

Take a look at more information on how to build accented characters in FontForge

  • Importing the accent separately gave me an error saying it was too complex (hard to believe). However, I was able to simply copy the existing accent from a pre-existing glyph in the font I was editing. Thanks for your help. – Thomas Reinstate Monica Myron Aug 30 '17 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.